Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RShal4
New Contributor I
428 Views

MT25Q 1G supported ?

Jump to solution

Hello,

 

We use MT25QL01GBBB8E12, but in platform designer we don't find this device , only MT25Q512 (512M).

 

Isn't MT25Q 1G supported ?

 

P.S.

if we try to configure with MT25Q512, we get an error in altera_qspi_controller_init(), becuase it identifies siliconID 33 (instead of 32), and comparing to expected sector size, it gives an error.

 

Thanks,

ranran

0 Kudos

Accepted Solutions
ShafiqY_Intel
Employee
67 Views

Hi RShal4,

 

MT25QL 1G is supported for Cyclone V, Arria V, Stratix V and Cyclone 10 LP.

Please refer to following link for more details on 3rd party flash supported by Intel FPGA (go to "Intel Supported Configuration Devices" --> "Intel Supported Third Party Configuration Devices"):

https://www.intel.com/content/www/us/en/programmable/support/support-resources/support-centers/confi...

 

We do not really recommend to use QuadSPI controller I for MT25Q device. Instead, we recommend to use QuadSPI controller II for MT25Q device.

If you want to use MT25QL device, please select MT25QU01G in QuadSPI controller II and select MT25QL01G in convert programming files

 

Thanks😉

View solution in original post

4 Replies
ShafiqY_Intel
Employee
68 Views

Hi RShal4,

 

MT25QL 1G is supported for Cyclone V, Arria V, Stratix V and Cyclone 10 LP.

Please refer to following link for more details on 3rd party flash supported by Intel FPGA (go to "Intel Supported Configuration Devices" --> "Intel Supported Third Party Configuration Devices"):

https://www.intel.com/content/www/us/en/programmable/support/support-resources/support-centers/confi...

 

We do not really recommend to use QuadSPI controller I for MT25Q device. Instead, we recommend to use QuadSPI controller II for MT25Q device.

If you want to use MT25QL device, please select MT25QU01G in QuadSPI controller II and select MT25QL01G in convert programming files

 

Thanks😉

View solution in original post

RShal4
New Contributor I
67 Views

Hi,

 

With 15.1 I get the following error when trying configuring 1G flash (from platform designer configured as N25Q0011G1240)

It only happens with 1G, so it seems that some error in IP in 15.1 (?):

 

....

Info (12134): Parameter "pll_subtype" = "General"

Error (12006): Node instance "addr_width_check" instantiates undefined entity "instantiated_with_wrong_parameters_error_see_comment_above". Make sure that the required user library paths are specified correctly. If the project contains EDIF Input Files (.edf), make sure that you specified the EDA synthesis tool settings correctly. Otherwise, define the specified entity or change the calling entity. The Altera Knowledge Database contains many articles with specific details on how to resolve this error. Visit the Knowledge Database at ....

 

 Double cloing the error we jump to file altera_epcq_controller_core.v:

if (ADDR_WIDTH != 24)   begin   initial begin   $display("Generated module instantiated with wrong parameters");   $stop;   end   instantiated_with_wrong_parameters_error_see_comment_above   addr_width_check ( .error(1'b1) );  

 

We then tried to port QuadSPI controller II from 18.1 IP into 15.1 , but than we get another error:

"COMPOSITION CALLBACK" IS NOT SUPPORTED.

 

 

Capture.JPG

 

I appreciate any idea,

 

Best Regards,

ranran

RShal4
New Contributor I
67 Views

Hi Wolfgang,

 

Is there any idea of the above errors?

Please help.

 

Thanks,

ran

ShafiqY_Intel
Employee
67 Views

Hi Ranran,

 

Did you able to port QuadSPI controller II from 18.1 IP into 15.1 using other than MT25Q 1G (e.g. 512, 256)?

 

If I not mistaken, MT25Q device supported in Quartus starting from 17.1

 

Thanks