Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
134 Views

Max 10 doesn't start

Jump to solution

Hello, I have a problem with the max 10. I have programmed it in the flash memory the code, but I am not able to start the FPGA.  I leave you a part of the schematic of the configuration pins.  

Raydem_0-1604516422738.png

Raydem_1-1604516647098.png

 

 

0 Kudos

Accepted Solutions
Highlighted
Novice
79 Views

Hello,

Fix it, It was problem of the quartus when it created the file. I don't know why...

Thanks 

View solution in original post

0 Kudos
6 Replies
Highlighted
121 Views

Hi,


Thank you for contacting Intel community.


  1. Max 10 does not need to power cycle.
  2. Try to check your design: pin connection, IP address, etc..
  3. Try a simple design such as LED blinking and see if the LED is blinking or not. If yes, that means there is no problem with your Max 10.

Let me know your concern.


Thanks.


Regards,

Aiman


0 Kudos
Highlighted
119 Views
0 Kudos
Highlighted
New Contributor I
108 Views

 Hi, it is not starting with a proven design? After programming and or at power up?

Try a simple design can be tested on board, IE an LED connected to JTAGEN, generate and load as SOF without programming Flash.

 Test Config_done and nConfig level, if not High test all other configuration input for high level.

 In case of failure try add 4 more resistor + 1 cap:

 10 KOhm pullup to CRC err (known) TDI TMS (less importance)

 1 KOhm pullDOWN to TCLK (Possible caveat)

 10-100 nF cap from CLR_n to ground

0 Kudos
Highlighted
New Contributor I
105 Views

I cannot modify message...

 About CRC Error, I checked two of my design, is connected to logic without pullup.

 Please try verify flash and tell us about what is on console.

 From what I remember I got troubled by some pin driving nConfig, ConfigDone, nStatus, are these pin free on your design or shared to?

0 Kudos
Highlighted
Novice
90 Views

Hello, 

 

Sorry for the delay.  I have had not enough time to proof it. This night will test it and comment you.

 

THank you

0 Kudos
Highlighted
Novice
80 Views

Hello,

Fix it, It was problem of the quartus when it created the file. I don't know why...

Thanks 

View solution in original post

0 Kudos