Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
19698 Discussions

NIOS Code not running from compressed internal Flash

DBarn22
Novice
371 Views

I have a FPGA design in Quartus Prime 18.1, including a NIOS II processor.

The original design used a 10M25DAF and I could program the design to internal Flash and it would run the code on power up - using Option 2 from AN730 (copying application from UFM to RAM).

Due to chip availability, we have moved to a 10M25DCF.  This has insufficient UFM for the code to fit uncompressed, so I have moved to Compressed - changing it in the on-chip flash IP and the device configuration.

All still builds and programs without error.  However, on start up the code simply does not run.  Can anyone give pointers as to how I go about diagnosing why not?

0 Kudos
6 Replies
DBarn22
Novice
313 Views

Addendum:

I have returned to basics.  Still with Compressed image I have tried the following.

1) Simple hello world.  Generated a simple bare metal Hello World application, that prints a counting result.  Programmed this into flash.  Rebooted.  This runs on start up.
2) MicroCOS hello world.  Multi-task Hello World example.  Prints counting number.  This also runs from flash on start up.
3) Simple Socket Server example.  Standard example.  tse_my_system changed to match my FPGA.  LED stuff removed.  Fixed IP, hard coded MAC.
Everything seems to program okay, but the app does not run.

IntelSupport
Community Manager
273 Views

Hello DBarn22,

 

We’d like to confirm your sample programs.

Don't all 3 examples work fine?

Thanks


DBarn22
Novice
259 Views

Example 1&2 run fine.
Example 3 (SSS) runs from JTAG, but does not execute when programmed into flash.

IntelSupport
Community Manager
177 Views

Hello DBarn22,


Do you still have the problem?

We are trying to duplicate the problem.


Thanks 


IntelSupport
Community Manager
134 Views

Hello DBarn22,

 

We tried to duplicate the issue on Max 10 Dev Kit and Quartus 18.1. But SSS design works fine.

Thanks


IntelSupport
Community Manager
119 Views

We do not receive any response from you to the previous question/reply/answer that I have provided.This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply