Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,126 Views

Problem on Linux PCI Express driver for an Avalon-MM DMA reference design

Hi Everyone,  

 

I'm following this link http://www.alterawiki.com/wiki/reference_design_-_gen3_x8_avmm_256-bit_dma_-_stratix_v to setup DMA communication for Stratix V device. I have successfully program the FPGA and the hardware side seems to be Okay. However, I have difficulty running the Linux Driver provided in the above link for Linux. Before telling what exactly the problem is it might be good to know that I have ubuntu and the kernel version is 3.19.  

 

So, trying to install the driver I got this message running dmesg.  

 

altera dma 0000:01:00.0: can't enable device: bar 0 [mem 0x00000000-0x000001ff 64bit pref] not claimed 

 

Worth to mention, when I run lspci command here is what I get: 

01:00.0 non-vga unclassified device: altera corporation device e003 (rev 01) 

 

So I assume there should be any problem with the hardware side because the linux can detect the pcie connected device.  

 

Is anyone have any thoughts what might be the problem ? Thank you in advance for any help.  

 

0 Kudos
4 Replies
senjd
Novice
153 Views

Hi, did you find anything on this. i am having the same problem

 

SLal01
Beginner
153 Views

I am also having the same problem. Any updates on this issue ?

MMate10
Beginner
153 Views

I have the same message for Stratix 10 DE10-Pro board.

senjd
Novice
153 Views

hi

can you check with lspci --xvv?

if you got the address for your bar then you might need to look into your driver. ​

Reply