Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LuisVelez
Beginner
220 Views

Problem with the waveform generator

I am trying to run a simple project consisting of 3 logical gates. However, after succesfully compiling the project, when I try to run the WaveForm, the project fails and displays the following error:

# do Circuito1.do

# ** Warning: (vlib-34) Library already exists at "work".

# Model Technology ModelSim - Intel FPGA Edition vcom 2020.1 Compiler 2020.02 Feb 28 2020
# Start time: 18:42:34 on Oct 08,2020
# vcom -work work Circuito1.vho
# -- Loading package STANDARD
# init_dbinfo() DATABASE ERROR: (sqlite3_open D:/luigi/OneDrive/UNAM/Semestre 7/Diseño Digital/Laboratorio/P2/simulation/qsim/work/_lib.qdb): unable to open database file
# mtilibWrite(): INTERNAL ERROR: Unexpected null object encountered
# ** Fatal: (vcom-9) Problem while writing token file "D:/luigi/OneDrive/UNAM/Semestre 7/Diseño Digital/Laboratorio/P2/simulation/qsim/work/_temp/vcomizyhxe".
# ** Note: Circuito1.vho(30): VHDL Compiler exiting
# End time: 18:42:35 on Oct 08,2020, Elapsed time: 0:00:01
# Errors: 1, Warnings: 0
# ** Error: D:/Apps/Quartus/ModelSim/modelsim_ase/win32aloem/vcom failed.
# Executing ONERROR command at macro ./Circuito1.do line 3

Error.

 

I attach a txt document conataining all the details form the message log.

0 Kudos
2 Replies
sstrell
Honored Contributor II
202 Views

I don't know if this is the issue for sure, but there are spaces in your directory path ("Semestre 7" for example).  Try a directory with no spaces.

175 Views

Hi, does the Strell's suggestion helps? Do you need further help on your case?

Reply