Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,223 Views

Programming problems with VMware and Windows 10

I am currently working on a project with a Cyclone IV E. I use Quartus Prime version 16.1.0 on a desktop Windows 7 64-bit machine and use a USB Blaster rev. B for programming and debug. Everything works just fine. 

 

In order to be able to program and debug at the installation location, I have installed the development system on Windows 10 64-bit running under VMware Fusion on a MacBook Pro. With this setup, everything works fine as well, except programming. When I try to program the device with the Quartus programmer, I get the following error messages: 

 

209040 Can't access JTAG chain 

209012 Operation failed 

 

Programming the same target board with the same programmer works perfectly from my desktop PC. 

 

A logic analyzer shows identical signal patterns on the JTAG interface. 

 

Running the JTAG Chain Debugger gives the following error messages: 

 

Error: JTAG chain problem detected 

Error: TDI connection to the first detected device UNKNOWN_NO_JTAG_ID might be shorted to GND 

Error: The TCK and TMS conections to the device before the first detected device UNKNOWN_NO_JTAG_ID might have a problem 

 

Both systems use the same device driver (2.12.0.0) for the Altera USB-Blaster, and I experience exactly the same problem with a Terasic USB-Blaster. 

 

Does anyone have an idea what may be causing this? Is this a Windows 10 or a VMware problem? 

 

Regards 

 

Erik
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
136 Views

Problem solved! 

 

In VMware, I changed the USB Compatibility setting for the virtual machine from 3.0 to 2.0, and now it works. 

 

This is obviously not a general problem with USB 3.0 and USB-Blaster, since my desktop PC has USB 3.0 ports as well. 

 

Both the Altera and the Terasic USB-Blasters work. 

 

Erik
Reply