Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
847 Views

Quartus Programmer does not recognize USB Blaster when Code Composer loads program

In Quartus Prime Programmer, after clicking the "Hardware Setup" button the USB Blaster hardware DOES appear or is recognized before loading my DSP through Code Composer. However, once the program STARTS to load the Quartus Programmer does not recognize the USB Blaster. If I stop Code Composer (hitting the red square) the programmer again recognizes the USB Blaster. The problem was originally found when trying to connect to the USB blaster when trying to use a signal tap file at the same time the DSP was loaded and running.  

 

Things I did and it still does not work: 

 

When the Programmer does NOT recognize the USB blaster, Windows 7 Device manager does recognize it and says the USB Blaster is working properly 

I have updated to the latest USB Blaster Driver 

I have reloaded and upgraded TI Code Composer 

I have replaced all the hardware with know working pieces including, target board, USB Blaster, TI XDS100 emulator, cables etc 

I have tried many different USB ports on the same computer 

 

Things I did to get it to work: 

I loaded Quartus on a separate computer and connected the USB Blaster to it, then ran Code Composer on the other computer and it did work 

 

There seems to be some problem with both Code Composer XDS100 working with USB Blaster on the same USB hub. 

 

One last note, this all worked fine at one time. The only thing that may have changed may be from automatic Windows Updates.  

 

I'm out of ideas, using two computers it not feasable. Any help would be appreciated. 

 

Thanks, Rich
0 Kudos
0 Replies