Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
19688 Discussions

Simple socket server - NIOS question

MK_ABQ
New Contributor II
1,343 Views

Hello,

We are using simple socket server template in eclipse. Arria 10 GX devkit is used as hardware. Can see that ethernet link is established from NIOS console. But would like to understand if ping/icmp is supported in simple socket server example?

we are trying to ping the board from host pc, but no success. Can you tell us if icmp/ping is supported in simple socket server template from Eclipse? or should we do something from our end?

 

Thanks

0 Kudos
1 Solution
KellyJialin_Goh
Employee
1,290 Views

Hi,

The icmp/ping function works on the Simple Socket Server example but ONLY on the Quartus 17.1 pro version. The Quartus version that you are using(18.1) cannot support the design example and ping function provided by Intel here: https://www.intel.com/content/www/us/en/design-example/714912/arria-10-nios-ii-simple-socket-server-...


I would suggest you to use Quartus 17.1 pro version to try out the design example above.


Thank you.

Regards,

Kelly


View solution in original post

11 Replies
KellyJialin_Goh
Employee
1,328 Views

Hi,

Greetings and welcome to Intel's Forum.

First of all, may I know the Quartus version. that you are using?


Here is a design example of the simple socket server that can ONLY be tested on the 17.1 pro Quartus Version to compare to your design: https://www.intel.com/content/www/us/en/design-example/714912/arria-10-nios-ii-simple-socket-server-...


One more thing to take note would be trying to use the SGDMA configuration instead of MSGDMA. Here is a reference that uses MSGDMA configuration for SSS for your reference:  https://www.intel.com/content/dam/support/us/en/programmable/support-resources/fpga-wiki/asset03/nio...


Hope to hear from you.

Thank you.


Regards,

Kelly


MK_ABQ
New Contributor II
1,320 Views

Hi Kelly,

I am using quartus version 18.1 with MSGDMA. When we use SGDMA, we are facing issue in Eclipse.  Can you help to answer if the socket server example supports ICMP/Ping?. I would just like to know if I can ping the development board from my host pc when using the socket server example?. It is not mentioned anywhere in the document. So, I would like to know if the ping function is implemented in the example or not?

Thanks. 

KellyJialin_Goh
Employee
1,291 Views

Hi,

The icmp/ping function works on the Simple Socket Server example but ONLY on the Quartus 17.1 pro version. The Quartus version that you are using(18.1) cannot support the design example and ping function provided by Intel here: https://www.intel.com/content/www/us/en/design-example/714912/arria-10-nios-ii-simple-socket-server-...


I would suggest you to use Quartus 17.1 pro version to try out the design example above.


Thank you.

Regards,

Kelly


MK_ABQ
New Contributor II
1,276 Views

Hi Kelly,

Thanks for your response. My company has installed only the following versions of quartus. 

 

1) Quartus 18.1 standard edition

2) Quartus 18.1 pro edition

3) Quartus 20.3 pro edition. 

 

If I choose to move to Quartus 17.1 pro, then it will require multiple justifications, and approvals from IT. It is going to take few weeks to months before we successfully get approvals and stuff. The question will be why can't we get NIOS working with ping functionality with latest available versions. 

 

In my scenario, we are basically trying to build a hardware system in platform designer with NIOS and TSE IP, and then use an available template from Eclipse, and get a PING functionality working.  Connect a host pc to Arria 10 GX (DK-DEV-10AX115S-A) development kit, and ping the kit from the host PC. So in this case, what would you suggest me?. I am new to NIOS, and trying to adapt an existing Intel design and work on it. 

Please advice the best possible solution for me.  

 

Thanks.

KellyJialin_Goh
Employee
1,270 Views

Hi,

In your case I do not suggest you to use Quartus 17.1 pro and the design example anymore.


You may want to try with lower level debug on TSE MAC first. Example like performing loopback testing to see where is the failure point. 1) Loopback within TSE IP 2) Loopback on External PHY chip 3) Then only finally loopback on external host side if possible. If loopback is working then most likely is your higher software application layer issue.


1. For internal loopback within FPGA TSE IP ,TSE IP user guide is available in below link:  https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug_ethernet.pdf . You can refer to chapter 4.1.9 for the “MAC local loopback” and chapter 4.2.8 for “PHY PCS/PMA loopback”

2. For on board external PHY chip loopback, you can refer to PHY chip datasheet for the register setting or consult the PHY chip vendor for support.

3. For on board external host loopback, you can check your board to see whether it’s able to perform cable loopback somewhere on board.


These are the debugging steps that I can advice and hope it is a workaround for you. Feel free to share on your findings.


Thank you.

Regards,

Kelly


KellyJialin_Goh
Employee
1,166 Views

Hi,

Any updates on the solutions provided? Did you manage to debug accordingly?


Thank you.

Regards,

Kelly


MK_ABQ
New Contributor II
162 Views

Hi Kelly,

Haven't had a chance to debug yet. Will try out TSE MAC loopback first and see the status. 

 

Btw, I do not quite get the 3rd step

" For on board external host loopback, you can check your board to see whether it’s able to perform cable loopback somewhere on board." - What do you exactly mean by this? Can you kindly brief it?

 

Thanks,

MK

KellyJialin_Goh
Employee
157 Views

Hi,

The third step's meaning is it would be on the loopback on external host side. However, do try out the debugging steps accordingly( Step 1 then 2) to see where the issue occurs.


Hope to hear on your findings.


Thank you.

Regards,

Kelly


KellyJialin_Goh
Employee
134 Views

Hi,

Any updates from your side on the debugging steps provided?


Regards.

Kelly


KellyJialin_Goh
Employee
106 Views

Hi,

As we do not receive any response from you on the previous reply that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


Thank you.

Regards,

Kelly Jialin, GOH




MK_ABQ
New Contributor II
95 Views

Hi Kelly,

Sorry about my delayed reply. Tried the project again with 18.1 standard version. Made some tweaks for our custom board, and built from scratch, and its working now.

Thanks

Reply