Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20557 Discussions

Stratix10 cannot be discovered as PCIE device in ubuntu

Yanhan
Beginner
444 Views

Hi, I tried the example design in UG20170 https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/avmm_stratix10_hard_ip+_ug.pdf.

I installed the driver and load the example design to the device successfully. However, when I use lspci to search the device, it cannot be discovered.  And the test program didn't run as expected becauce the pcie device was not found.

The environment is Ubuntu20.4. The device is Stratix10 1SG280LN2F43E2VG.

0 Kudos
5 Replies
SengKok_L_Intel
Moderator
417 Views

Hi,


After you program the SOF to FPGA, did you reboot the host for it to perform the PCIe link training and enumeration?


Regards -SK


0 Kudos
Yanhan
Beginner
413 Views

Yes I reboot the host, but it still cannot work.

0 Kudos
Yanhan
Beginner
413 Views

Thank you for replying. I reboot the host but it still cannot work.

0 Kudos
SengKok_L_Intel
Moderator
412 Views

Hi,


 

Could you please add the following signals into the signal tap to check the PCIe link status?

 

  1. ltssmstate[5:0]
  2. lane_act[4:0]
  3. link_up
  4. currentspeed[1:0]
  5. pin_perst
  6. npor


Regards -SK


0 Kudos
SengKok_L_Intel
Moderator
376 Views

If further support is needed in this thread, please post a response within 15 days. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 


0 Kudos
Reply