Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
19528 Discussions

Why device has stopped receiving configuration data when programming?

Jiayi_H_Intel
Employee
415 Views

Hi,

I am initializing 2 Gen4x8 R-tile Pcie HIP(one is upstream/upstream, the other is downstream/downstream). Compilation using Quartus 21.2 passed successfully.

But when I try to program the sof file to device, programmer reports errors:

Error(18950): Device has stopped receiving configuration data

Error(18948): Error message received from device: Internal error. (Subcode 0x001A, Info 0x00000000, Location 0x00004400)

Error(22248): Detected an error during configuration. Refer to the Configuration User guide for details on debug guidelines. Check the latest Intel Quartus Prime software release for possible fixes.

Error(209012): Operation failed

Any ideas about it?

0 Kudos
6 Replies
JohnT_Intel
Employee
397 Views

Hi,

 

Could you confirm if you are providing the refclk to the PCIe IP on your board?

 

You may refer to https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/agilex/ug-ag-config.pdf Chapter 7 on how to further debug the issue.

 

Jiayi_H_Intel
Employee
392 Views

Hi, 

Here is the device I use: AGIB027R29A1E2VR0

And I am using these pins for ref clock:

For EP side:

refclk_pcie_14c_ch1_p(n) : CR70 : input : Current Mode Logic (CML) : 0V : 14C

refclk_pcie_14c_ch1_p : CU68 : input : Current Mode Logic (CML) : 0V : 14C

refclk_pcie_14c_ch0_p(n) : DM70 : input : Current Mode Logic (CML) : 0V : 14C

refclk_pcie_14c_ch0_p : DR68 : input : Current Mode Logic (CML) : 0V : 14C

 

For RP side:

refclk_pcie_rp_ch0_p(n) : FV26 : input : Current Mode Logic (CML) : 0V : 15A

refclk_pcie_rp_ch0_p : GA27 : input : Current Mode Logic (CML) : 0V : 15A

refclk_pcie_rp_ch1_p : GY26 : input : Current Mode Logic (CML) : 0V : 15A

refclk_pcie_rp_ch1_p(n) : HC27 : input : Current Mode Logic (CML) : 0V : 15A

 

Anything incorrect with my assignment?

JohnT_Intel
Employee
386 Views

Hi,


May I know if the refclk have a valid clock signal when you performed programming?


Jiayi_H_Intel
Employee
363 Views

Hi, 

15A seems not work. After changing to 15C, it can be programmed. Thanks!

JohnT_Intel
Employee
355 Views

Hi,


It looks like there is no clock signal from 15A pin which cause the configuration to failed. Please let me know if you have any other queries.


JohnT_Intel
Employee
262 Views

We do not receive any response from you to the previous question/reply/answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply