Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
826 Views

jtag issues De0-nano-soc

I've tried this on three machines with no luck soooo... 

 

Current Platform Quartus 15.1 / CentOS release 6.7  

 

I've downgraded this box from usb xhci which had issues  

 

Now - as root 

 

# jtagd --foreground --debug 

JTAG daemon started 

Using config file /etc/jtagd/jtagd.conf 

Remote JTAG permitted when password set 

USB-Blaster firmware download ok (23ms) 

USB-Blasters reconfigured, waiting for them to come back 

USB-Blaster "DE-SoC" firmware version 1.35 

USB-Blaster endpoints out=04(512), in=88(512); urb size=4096 

USB-Blaster firmware for 09FB/6010 is version 1.35 

USB-Blaster added "DE-SoC [2-1]" 

Device /dev/bus/usb/002/036 remove 

Device /dev/bus/usb/002/037 add 

 

and as soon as i run  

#jtagconfig  

1) DE-SoC [2-1] 

Unable to lock chain - Hardware not attached 

 

this is nonsense as above it found the firmware ver ....  

& the debug stream says : 

 

USB-Blaster port (/dev/bus/usb/002/037) can't reset interface (71) 

USB-Blaster port (/dev/bus/usb/002/037) can't reset interface (71) 

 

 

permissions are wide open 

crwxrwxrwx. 1 root root 189, 162 Jul 19 20:08 /dev/bus/usb/002/037 

 

I have 'occasionally ' got jtagconfig to recognize the chips on the board but as soon as i try writing / query from SignalTap it complains the same refrain: 

"Unable to lock chain - Hardware not attached" 

 

 

works fine with a DE0-nano ...  

 

so any clues ? --  

I've pretty much debuged with a external logic analyser( and printf) till now  

... but that is getting difficult for many aspects ....
0 Kudos
0 Replies