Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18457 Discussions

max10 remote update issue

GZhan28
Beginner
203 Views

I am trying to implement the remote system update feature in MAX10 based on intel RSU training document.

At current moment, i am already able to write rpd file to my cfm2/3 as image 2 through discrete uart module(not nios II ), while image 1 was programmed  as backup image.

What i see is after rpd written in, the reconfiguration was triggered, and everything seems correct from the LED pattern change.

However, after I power cycle my board, the FPGA boots to image1, instead of booting from my newly programmed image 2.

For the config SEL pin, i set it high externally, and enable this feature in quartus. i also force config SEL to 1 by write 0x3 to avmm_rcv_address "001" everyt time board power up. So should not be the config SEL issue.

 CRC issue? but i do see LED pattern change after first remote update, means update succeed.

Can anyone help me find the possible reason?

0 Kudos
1 Solution
YuanLi_S_Intel
Employee
191 Views

First of all, have you change the setting to boot from application image instead of factory image?


Usually, the device will boot the application image for several times (If it is set to boot from application image at first) and if it is no able to boot, then will go to factory image (image 1).


View solution in original post

1 Reply
YuanLi_S_Intel
Employee
192 Views

First of all, have you change the setting to boot from application image instead of factory image?


Usually, the device will boot the application image for several times (If it is set to boot from application image at first) and if it is no able to boot, then will go to factory image (image 1).


View solution in original post

Reply