Rapid Storage Technology
Intel® RST, RAID
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2034 Discussions

Intel Matrix Storage Manager - Rebuilding

Avon
Novice
1,428 Views

I have a Raid 5 drive created from 3 500Gb WDC drives.  It was working perfectly.  It is not intended as a boot drive.

Today, I changed the drive I thought contained the boot drive (a 4th WDC 500Gb drive) with an SSD drive.  When I rebooted inorder to install the new copy of Windows 10, it was clear I'd substituted the SSD for the wrong drive.  I switched off, correct the mistake and have now successfully loaded Windows 10 to the SSD.  The other 3 drives are connect and seem correct, but the Raid say's it needs to be Rebuilt and that that will be accomplished by the operating system. 

Windows 10 has give not indication that it is doing so and, surprisingly, the bios seems to thing the Raid volume is bootable - though it doesnt work if I try.  I wonder if one of the following is true:

  1. It thinks its bootable because at one stage I'd got a bootable drive in the 3 remaining disks?
  2. Windows 10 is not capable of 'rebuilding' the volume because its somehow not compatible with the Intel Matrix Storage Manager.
  3. I'm impatient and if I leave it until tomorrow everything will be fine (or alternatively, I've still swapped the drives incorrectly and by tomorrow it will be totally unrecoverable!).

Grateful for any thoughts.

Regards

Peter

0 Kudos
1 Solution
Avon
Novice
1,409 Views

Hi Scott,

Well it doesn't appear to be doing anything . I did download some software from MSI's website (the motherboard manufacturer), but I still see no evidence of anything happening - where would I look to see something and how long would you expect it to take (Raid 5 comprising of 3 500Gb discs, should be approx 1TB capacity).

Thanks for your comments - I not feeling hopeful.   Thankfully, I think, most if not all current information is in a cloud.

Regards

View solution in original post

0 Kudos
7 Replies
n_scott_pearson
Super User
1,415 Views

Yea, when the RST firmware detected that a drive was missing from the array, it placed the array into a degraded state. Just restoring the drive to the system is not going to automagically fix it (RST simply cannot trust that its contents haven't been corrupted). Provided you have an Intel RST software package installed, this should result in the array being rebuilt in the background while Windows is running. If your system is so old that there is no Windows 10 RST package for it (i.e. only the inbox driver MS provided is available), I hope that it will still rebuild, but I have my doubts whenever it comes down to relying on inbox drivers.

...S

0 Kudos
Avon
Novice
1,410 Views

Hi Scott,

Well it doesn't appear to be doing anything . I did download some software from MSI's website (the motherboard manufacturer), but I still see no evidence of anything happening - where would I look to see something and how long would you expect it to take (Raid 5 comprising of 3 500Gb discs, should be approx 1TB capacity).

Thanks for your comments - I not feeling hopeful.   Thankfully, I think, most if not all current information is in a cloud.

Regards

0 Kudos
n_scott_pearson
Super User
1,403 Views

Some information about your machine would be helpful. Please download and run the Intel System Support Utility for Windows and have it save the report to a file. Then, using the Drag and drop here or browse files to attach dialog below the edit box for the body of your response post, upload and attach this file to the response post.

...S

0 Kudos
Avon
Novice
1,397 Views

Hi Nick,

The Bios now shows the drive as being 'Normal', but the drive is still not visible.  I also notice that it is marked as Bootable which I don't believe it should be; additionally, at boot up I'm shown two Windows 10 boot options.

I wonder if I've swapped out the wrong drive and now have 2 of the original Raid set plus the original boot disk?  I had thought that that was what I did originally, and that now I have the correct disks in the Raid set.

Really appreciate your help.

Regards

Peter

0 Kudos
Avon
Novice
1,392 Views

Hi Nick,

Further to my last I decided to look at the 'Disk Management' utility and discovered that while the Raid drive was working it had no Drive letter associated with it.  I gave it a drive letter and it now seems to be working perfectly.

The only issue outstanding is that it remains 'Bootable' and I have two options for starting Windows 10, it would be good to remove this option, but I haven't found how to do so as there's no option for it in the Raid Controller that I can find.

Best Regards

Peter

0 Kudos
n_scott_pearson
Super User
1,341 Views

Was Disk Management saying the volume wasn't initialized? Didn't have partitions? I thought these were the only things that would stop drive letter assignment. Regardless, it's moot if you are alive and see everything ok.

You'll have to talk to your motherboard vendor regarding why their BIOS might be adding an additional boot drive entry.

...S

0 Kudos
Avon
Novice
1,336 Views

I hadnt thought to look at Disk Management until after it appeared to be ok in the BIOS, but it looked to be perfectly ok.  All I did was assign a drive letter - it seemed to be that the drive just needed to be 'mounted' to use an old term.

Strange.

I'll contact MSI.

Many thanks for your help

0 Kudos
Reply