Rapid Storage Technology
Intel® RST, RAID
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2032 Discussions

Intel RST: SRT + RAID 1 on Gigabyte Z68XP-UD3 board


Build a new system based on intel 2500k CPU and Z68 motherboard.

I had two identical 500 GB drives already, so I bought a 120 GB SSD to use as a cache.

I want to use Intel Smart Response Technology to accelerate my RAID 1 array.

Despite some research, I cannot figure out if a RAID 1 array can be accelerated with SRT.

This is what Gigabyte has to say about it:

"Since we haven't tested whether RAID 1 configuration can work with Intel RST + SRT, we can not promise it works well with RAID 1 configuration. Therefore, we will test this case and when the result comes out, we will inform you immediately."

"After confirming and testing, Intel RST can't be work with RAID configuration, since RAID configuration have been accelerated already. However, it will be fine to do Intel RST with HDD which do not make RAID configuration. We are sorry for the inconvenience."

If SRT on RAID is not possible, why does the intel Rapid Storage Technology app not give a warning? The interface seems to support it!

And is RAID 1 "in itself" really accelerated? I thought that was RAID 0!

Should I use the 120 GB SSD as ReadyBoost instead? I bought this motherboard thinking I would be able to use SRT, that was one of the features that made me buy it in the first place.

After Reboot today, I get this message in the RST taskbar applet:

Accelerate (Intel SRT)

The accelerated disk or volume associated with the cache device is inaccessible, and

the overall performance is no longer optimized. Please reconnect the accelerated disk or volume, or click Accelerate for more troubleshooting options.

SSD on port 0: Normal

What is that supposed to mean? The "accelerated volume" is on the RAID 1 HDD, and they certainly are available. That's my system boot disk!

Also the Verify checker finds 95 verification errors on the RAID 1 volume (this took hours to reach 100% checked), but seemingly does not repair them.

Thanks for taking the time to read this post!

I'm very confused by SRT, and there doesn't seem to be a dedicated forum for intel RST/SRT topics.

========ADDITIONAL INFO ==================

I followed the instructions in the printed guide:

1. In BIOS, enable XHD & RAID. (selecting XHD forces RAID)

2. Set up two 500 GB of identical make and model as RAID 1 (mirror)

3. Set up to boot from RAID Volume0

4. Installed Windows 7 to RAID array.

5. Installed drivers from the mobo DVD-ROM.

6. Enabled 'Accelerate' in Intel RST applet (as per manu

7. Once, after windows update, get blue screen before login screen

8. Reboot, hold Ctrl+I to enter RAID menu:

Intel Rapid Storage Technology - Option ROM -

RAID Volumes:


ID Name Level Size Bootable


0 Volume_0000 RAID0(Stripe) 47.8 Yes


1 Volume_0001 RAID0(Cache) 64.0 No


2 Volume0 RAID1(Mirror) 465.8 Yes

Physical Devices:


Port Device Model Size Type/Status(Vol ID)


0 OCZ-AGILITY3 111.7 Cache Disk(0,1)


2 wdc wd5000aads-0 465.7 Member Disk(2)


3 wdc wd5000aads-0 465.7 Member Disk(2)

9. I changed nothing, and rebooted into Windows 7. This time it worked.

10. In Intel RST dock applet, under Storage System View, it shows



112 GB ---- SSD*, RAID 0, Data volume, 48 GB -- SRT*, RAID 0, Cache volume, 64 GB



466 GB ---- Volume0, Accelerated, RAID 1, 466 GB
0 Kudos
3 Replies
Valued Contributor III


We have provided the option to accelerate standalone hard drives and also RAID volumes, that is why Intel(R) Rapid Storage Technology gives you the option to do it and does not show any alert message on this.

We have just tried one of our systems based on the Intel(R) Z68 chipset with a RAID 1 volume and it works just fine. Verified the array and no errors are detected running in Enhanced mode or maximized mode.

In this case, you might be having an isolated issue with the system configuration on your computer or a limitation of this feature on your motherboard as advised by your motherboard manufacturer.

Try using other drives and SSD to accelerate, or try using an standalone drive and see if you still get the same type of error messages.

0 Kudos

Ok, i have a few related question then...

Can you put two 20gb slc ssd drives in a raid0 and use that to accelerate a raid0? if the answer is no, could you use a port multiplier to do that? Is there any sata3 port multiplier available anywhere? would the z68 support them?

0 Kudos

I want to add that I've also built a system with 2x 160GB WD Caviar SE drives + 90 GB SSD (OCZ Agility 3).

The WD drives are connected in RAID 1 and accelerated with a 18 GB partition on the SSD. I've also installed the OS on the remaining 65 GB partition on the SSD (needed the "F6" drivers to do that). Everything works really snappy and I could check the array being accelerated with HD tune (there were spikes with >400 MB/s read speed on the array).

The only problem I've encountered is that it is not possible to have more than 1 volume on an array (originally I had two volumes, one RAID 0 and one RAID 1). This can be checked in the help file that comes with RST.

0 Kudos