Rapid Storage Technology
Intel® RST, RAID
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
1897 Discussions

Intel Rapid Storage Deleted my HDD


Intel Rapid Storage was bugging me to do something for ages, so I clicked on it and let it do its thing. It deleted my HDD or converted it into a recovery. And i cannot revert this.


I did my research on this and found a confirmed solution in the forums but i tried it and it did not work for me. Here is the link of the solution. 




When i tried the said solution I encountered these messages; 



The first line that is Turkish says ' There is not enough RAM to process this command.'. I have no idea what this means, i have 16 GBs of RAM how can it not be enough?


I am honestly lost on this, I also tried opening a panel during the boot that opens with ' CTRL + I ' which some threads said I could fix the issue in the menu that comes with ' CTRL + I ' but when i do the combination nothing happens.


My laptop's warranty has expired and the local Acer Turkish Customer Service is a joke. Please help me solve this annoying problem.


0 Kudos
4 Replies
Hello GÇakı, Please try these steps: -At POST, use CTRL-I to enter the RST BIOS Extension. -Mark the drive as "Non-RAID". -Reboot your system. Since you mentioned that you are unable to access the BIOS extension with the CTRL+I combination then please get in contact with Acer* support so they can tell you the combination the use for that BIOS extension of the Intel ® Rapid Storage Technology. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation

I also have this problem, and that solution does not work. There is no "combination the use for that BIOS extension of the Intel RST". Acer does not have a way to access that BIOS. I have also tried all other legacy POST shortcuts Google could find. I don't care about data preservation, OS preservation, or anything; I just want my HDD back from Intel RST so I can uninstall it without permanently losing the information. The Intel RST even prevents reformatting of the HDD!


Pressing CTRL+I during POST was not doing anything for me. So i did some research on the matter.


https://community.acer.com/en/discussion/551113/how-to-enter-rst-bios ( egydiocoelho's solution )


As you can see in the linked thread i changed the UEHFI setting in BIOS to Legacy.

After this i tried opening the CTRL+I menu during POST and it did not work again.


I started getting this screen; https://i.ibb.co/51J94Gy/kenan.jpg


After the said change i tried accessing normal BIOS via F2 but it was not working neither. Nothing was working really.


Right now, i can not open my pc, im getting the black screen i posted the image of.

During post i tried pressing, F2, F8, ALT+F10, F12, DEL, CTRL+I nothing worked.


I am guessing that my HDD is still in recovery state. And my SDD is still normal, but since Legacy UEHFI mode forces my pc to run from HDD, it is not running because Intel Rapid Storage took my HDD as a hostage. And for the reasons unknown i can not reach the normal bios.


Excuse me but why was this useless program called Intel rapid storage was pre-loaded into my pc? And nagged me to do this constantly over and over again and once i did it, there was no option to take it back? Is this some sort of a scam to make users buy a new HDD? Why can't I just undo what it has done? I am getting really impatient and pissed.


Hello GÇakı, Thank you for your response. In this case, you must contact Acer* support so that they can guide you to the BIOS extension of Intel ® Rapid Storage Technology, there could be different methods to get there, the different manufacturers decide how to set it up so it is recommended to first get in contact with them. Regards, David V Intel Customer Support Technician Under Contract to Intel Corporation