Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FG
Beginner
768 Views

RST driver 17.5.1.1021 "Intel Optane(tm) Memory Pinning. Unable to load DLL 'iaStorAfsServiceApi.dll'. The specified module could not be found (Exception from HRESULT:0x8007007l Windows Explorer)"

Hello,

Why is SetupRST installing Optane memory Pinning Extensions even if the computer does not support Optane ?

Also if the version of the RST is not compatible with the machine, why is it installing it ?

I can see that the module iaStorAfsServiceApi.dll exists in C:\Program Files\Intel(R) Rapid Storage Tecnology, so why "could not be found" ?

I found two ways to get rid of the error:

1) Uninstalling the Optane Memory Pinning Extensions.

2) Reinstalling RST 17.5.1.1021 seems to cure the problem too.

Is this version of RST compatible with the CHIPSET of the MSI-GT70-0NC ?

I assume that if Optane is not supported it should not try to use it ?

 

The previous version of RST installed was 16.8.2.1002

Please let me know the latest version for this machine, the Intel DSA is not much help in this case.

I saw a previous report on this error, but it was closed without a clear answer. This is the Latest Windows 10 1903 Build 18362.267. Also tried with Win 10 Preview build 18945.1001 with the same results and the same workaround.

I attached the SSU.TXT for the MSI-GT70-0NC.

Thanks.

F.G.

0 Kudos
4 Replies
LeonWaksman
Super User
145 Views

  1. You did right - the Intel RST Driver and the Optane extension is corrupted during Windows 10 upgrade to version 1903.
  2. Uninstalling the old version and installing the latest version solves this problem. The Optane extension is included in the latest RST Driver.
  3. However if you don't use Optane Memory or RAID configuration, you don't need the RST software.
  4. See here for additional explanation: https://www.intel.com/content/www/us/en/support/articles/000030517/memory-and-storage.html

 

Leon

 

 

FG
Beginner
145 Views

IntelRST17.2.PNGHi LWAKSMAN.

1) I don't have Optane Memory, but my system uses an mSATA SSD in Intel Raid 0 configuration. So I believe I still need RST and the driver for the Intel Chipset SATA/PCIe RST Controller.

Today I ran again Intel DSA and it downloaded RST version 17.2.0.1009 to replace 16.8.2.1002 and states that it is the latest version, but when I look at the support site it shows that the latest version is 17.5.1.1021. So, do I trust Intel DSA or the support site ? Both versions seem to work fine after I reinstall them, perhaps Intel DSA is not up to date ?.

 

2)The next question is: Since I don't have Optane Memory, should I uninstall the Intel Optane Pinning Explorer Extensions ? Do they serve any purpose in my case ?

Or are they just wasting time and resources ?

Thanks, for your help.

LeonWaksman
Super User
145 Views

  1. The latest version on the Intel RST Driver is 17.5.1.1021 https://downloadcenter.intel.com/download/28966/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf... . So, if the DSA reports other version as latest, it is wrong. Update this driver manually. You may check also if you have the latest Intel DSA installed: https://downloadcenter.intel.com/download/28425/Intel-Driver-Support-Assistant?product=128824 and if not please update DSA.
  2. Since you don't have Optane Memory you should uninstall the  Optane Pinning Explorer Extensions. Any way, this function is now included in the RST package.

 

Leon

 

FG
Beginner
145 Views

Leon,

1) The Intel DSA is the latest 19.7.30.2, I guess it is not up to date.

2) As you suggest, I'll install RST 17.5.1.1021 and then unisntall Optane Pinning Explorer Extensions

Thanks, FG

Reply