Rapid Storage Technology
Intel® RST, RAID
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2030 Discussions

SSD Questions (Intel 510, 120 GB, setup & Intel Solid-State Drive Toolbox)


When I was setting up the Intel 510 120 GB SSD for install I noticed two reserved partitions in addition to the system drive.

Partition layout:

1. 'Reserved MBR' of about 120 MB

2. The expected 100 MB partition.

3. The 118 GB System partition.

I thought that this was odd. The SSD is out of an unopened box from Microcenter.

Following that after I had everything setup and installed in windows I noticed that the Intel Solid-State Drive Toolbox was not able to fully communicate with the Intel 510 SSD.

Firmware had been updated (it _came_ updated, it shipped with the lastest available apparently).

1. The Intel SSD Optimizer is greyed out and not selectable.

2. Under Quick Diagnostic Scan and other tools the drive Model is reported as: Unknown 120 GB.

The board is the ASUS Rampage 4 Extreme and the SSD is plugged into the Intel Sata 3 connector.

Intel C600 Series SATA AHCI Controller (Driver Also on the board are expanded Sata controllers: Asmedia 106x SATA Controller (Driver

Does anyone have any idea where the extra 'reserved MBR' partition came from and/or how to resolve the issue with the Solid-State Drive Toolbox?

-- Added 201201161130

Read Scan under the tools reports:

The Intel SSD Toolbox cannot communicate with the selected Intel SSD. Consider changing to another storage driver compatible with your system and try the tool again.

Last I checked the drivers I installed were the updates to the shipped/packaged drivers.


The upgraded version of the Intel Rapid Storage Technology enterprise software takes a long time to start up -- at least a minute, maybe longer. It is also not driver signed. The mobo packaged version had neither of these issues.

0 Kudos
5 Replies

I solved a similar problem, so I hope this helps you.

I installed a 120GB 510 on a SATA 3 port of my ASUS P6X58D Premium. After installing Win7 64, I ran the toolbox and it worked fine. Then I proceeded to install my mobo drivers and when I ran the Toolbox again several days later, it listed the SSD as an unknown model.

I checked back on the ASUS download site and realized the SATA driver I installed was a beta, listed as Marvell 91XX Controller Beta Driver V1.2.0.1002. The next one down the list is Marvell 912x Controller Driver V1.0.0.1036. I grabbed the second one, replaced the beta and now the Tollbox works fine.

Edit: Actually, it doesn't. Although it now recognizes the drive, it won't let me run the Optimizer. I installed the last driver on the list, the Intel Matrix Storage Manager Driver V8.9.0.1023 and now everything works. I guess the toolbox doesn't like Marvell.

Good luck.



I will give that a shot and see if rolling back all of the drivers has an effect. The driver in question is Intel though and not a third party -- the third party controller is not what the Intel SSD is plugged into.

Devices I have connected to the third party controller do not show up in the RST and the SSD does show up there.

0 Kudos

The only change is now RSTe reports all connected devices to be SCSI devices in 'DETAILS' even though on the outside report it lists them as SATA devices...very odd.

I will probably reinstall at some point as the system is getting littered with multiple abandoned (rolledback, overwritten) driver installations and possibly try a different SSD brand.

And I just noticed this little gem in thread 14587

But as I alluded to above, I don't think the RST driver is completely uninstalled. I would really just reinstall windows (I am using Windows 7 64) and do not install the RST driver if you don't have a RAID configuration. That is what I did for my machine. I have an Asus Rampage IV Exteme board. I just noticed today that Asus has removed this Intel SATA driver from the SATA driver section in the downloads for this motherboard. They know there's an issue here. You may want to look at the threads at the Asus website on this. It did help me and I hope this helps you. I don't know what the status is on resolving the issue with this driver.

How annoying; I have this same mainboard. I will possibly try a reinstall without touching the RST I guess.

0 Kudos

I completely rebuilt the system from the OS installation level and reinstalled all of the drivers (with one exception) and through the use of restore points I narrowed down the Intel Solid-State Drive Toolbox failure to a problem with both the packaged and the updated versions of the Intel Rapid Storage Technology enterprise (or the installation/setup script being used by Intel is broken/breaking something). The Intel Solid-State Drive Toolbox works fine when the RSTe is NOT installed on this system.

Both versions of the RSTe (the ASUS R4E motherboard package and the downloaded update) resulted with the Intel SSD Toolbox failing to communicate with the Intel 510 SSD.

Only the most recent version of the RSTe identified connected SATA devices to be SCSI devices when examined under the RSTe disk detail link.

In the earlier RSTe version a note popped up about a detected connected SCSI device but there was nothing mentioned in the RSTe disk detail link about it. I do not recall the disks being noted to be SATA devices or any specific type of device when viewed under the details link come to think of it (again, this is specific only to the earlier version of the RSTe).

During the install process both versions of the RSTe briefly identified the Intel SSD and the Western Digital Velociraptor 600 GB as removable devices. This went away after the post-installation reboot.

Both versions of the RSTe would take at least 2 full minutes to finish 'detecting' connected devices after _every_ OS reboot.

(The secondary Asmedia SATA 3 6/GB Controller identified the connected Western Digital 2 TB HDD as a removable device. This did not go away but since it is probably not related to the Intel issues it is just a side note.)

Motherboard: Asus ROG Rampage IV Extreme

Chipset: Intel, set to AHCI

Integrated secondary controller: Asmedia, set to AHCI

SSD: Intel SSD 510 120GB

OS: Windows 7 Professional x64

Configuration: Intel Sata 3 Controller: Intel 510 120 GB SSD

Intel Sata 3 Controller: Western Digital Velociraptor 600 GB HDD

Intel Sata 2 Controller: Samsung CD/DVD R/W

Asmedia Sata 3 Controller: Western Digital Caviar Black 2 TB HDD

Problem: Apparent Intel Rapid Storage Technology enterprise driver

incompatibility with this hardware configuration with BIOS set to

AHCI on the Asus ROG Rampage IV Extreme.

I am as yet not sure if I want to try RAID with the driver issues at hand.

Has anyone here put a pair of Intel 510 SSD into RAID 0 for OS on the R4E?


0 Kudos

This was answered in another thread where it was clarified that the IRSTe is specifically intended for RAID.

0 Kudos