Rapid Storage Technology
Intel® RST, RAID
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1795 Discussions

Samsung 470 SSD 256GB using 1.5 Gbps on 3.0 Gbps capable chipset

idata
Community Manager
1,103 Views

Currently, I am using a Samsung 470 SSD with a laptop, and while it seems to be running OK with Intel RAID Controller (with single drive). When I update to the latest version of Intel RST 10.xx drivers, it seems to drop the auto-negioation link of the SATA interface to 1.5 Gb/s instead of 3.0 Gb/s on this SSD

Is there any way around this issue? It does overall affect the speed of the SSD.

Model name: SAMSUNG 470 Series SSD

 

Serial# : S0MTNEAZ900569

 

Firmware: AXM0701Q

 

RAID Controller: Intel ICH8M-E/ICH9M-E/5 Series SATA RAID Controller using drivers Intel RST 10.1.0.1008

 

OS: Windows 7 Ultimate

The red bench is version 8.6.2.1012 (Windows default) drivers and the blue is the RST 10.1.0.1008. I've also tried the 9.6 version of RST, performance was identical to 10.1.0.1008.

0 Kudos
1 Reply
idata
Community Manager
217 Views

After wayyyyyyyyyyyy too much formatting/reinstalling. Uninstalling storage drivers, etc etc. I've finally figured out why it was dropping me to 1.5 Gbps -- seems like that the RST drivers when installed on a laptop it enables a feature to 'power save' -- Link Power Management (LPM)

 

 

The fix was to change in the registry

 

HKLM\SYSTEM\CurrentControlSet\services\iaStorV\Par ameters\Port0 (corrosponding port that you are having the problem with. Change the LPM DWORD value to 0, and it'll disable the LPM and put it back into 3.0 Gbps intead of 1.5 Gbps.

 

 

Posted for posterity's sake in case anyone ever have this same issue.

 

 

Caused me over 24 hours of grief.
Reply