Rapid Storage Technology
Intel® RST, RAID
2077 Discussions

X25M 80GB installed as AHCI, switched to RAID...


Hi, I finally got my first taste of an SSD with the X25M 80GB. I had some initial issues which I resolved by switching from SATA port 5 to 1, and also unplugging my two RAID 0 Seagate 7200.12 500gb HDDs. I changed my BIOS to AHCI thinking this was a smart move (I guess I didn't read enough) and reinstalled Win 7 64 bit (didn't do a clean wipe either...). First thing I did was delete Windows.old on the SSD, then downloaded updates and some apps I regularily use, as well as RST 9.6 (newest one) because obviously I'd have RAID HDDs installed and want to have TRIM. So, after getting it set up Win 7 was running beautifully - I did a bunch of the recommended optimizations too (except I left Indexing on). I then plugged in my HDDs and set the BIOS to RAID which obviously caused a BSOD when loading Windows. After some googleing (on AHCI) I found a Microsoft fix which actually worked, and switching back to RAID everything worked fine. Except that RST doesn't show my SSD now, only the RAID volume. When I had it on AHCI, I could see my SSD (HDDs weren't plugged in). I'm wondering, then, if maybe TRIM isn't getting passed on because it's not reconized in RST?

I wouldn't mind doing a re-install but only on the condition that I don't have to spend hours and hours re downloading and re installing everything. I did a Windows backup, would it be safe to assume I can just copy the image after a fresh install and everything will be as it is now? (Windows updated, iTunes and Opera installed, among other apps).

I did install the SSD Toolbox. It shows my SSD but I don't really know what I'm doing in there. The optimizations show they're done. I didn't run the tool that refreshes the SSD back to "like new" because if TRIM is working, I shouldn't have to (right?). I haven't done any benchmarks yet either, but that's certainly a possiblity (I'm only experienced in GPU and CPU benches and I don't want to put too much excessive wear on the SSD but I'm open to trying).

I don't know if this tells you anything, but for some reason after setting up the RAID volume my shutdown time is much longer. Not really an issue since I can tell I'm still getting faster loading times, but I don't know what would cause the shutdown to slow. There's only 1 app running off the HDDs and that's Steam.

1 Reply

Hi just an update, maybe someone can help out... lots of views here but no answers. I've ran AS SSD benchmark. My initial tests were pretty good and inline with what other people were achieving. Here's an image:

I figured all's good. However, I reran the test a couple times this evening and scored a lot worse on the 4K writes as well as acc time. The only thing I changed was that I moved Crysis Warhead onto my SSD and used an mklink to reference it out of Steam. This worked fine. This afternoon I was playing around changing the ACPI APIC support and ACPI 2.0 support. I found that no matter what I need ACPI APIC enabled for Windows 7 to boot, and I noticed that sleep only seemed to work with ACPI 2.0 enabled as well... I ran some benchmarks to try with 2.0 both on and off and didn't see a noticeable difference in scores (actually the best score was with both enabled). I'm not exactly sure what EuP is in the BIOS - my research shows something to do with minimizing the CPU's power usage when in sleep, but I don't know that it really has any effect. It's currently off.

So the only other thing I've noticed is that in the benchmarks it says I'm using iaStorV as the driver, which apparently corresponds to RST (which I'm running the latest version, Apparently this just tells me that the previous switch from ahci to raid worked. I'm still a little confused why my SSD doesn't appear in the RST info panel tho, but maybe it's just because it's not actually in a RAID volume...?

Anyway here's this evening's benchmark:

Oh, and before you ask, yes I did try running the Intel SSD Toolbox optimizer... I also disabled prefetch, superfetch, automatic restore points, and I have my page file set onto the RAID volume (usage is nil tho, with 8gb RAM it shows 209mb paged 81mb nonpaged under task manager)