Rapid Storage Technology
Intel® RST, RAID
2001 Discussions

intel rapid technology shows incompatible volume in RAID0 after system crash!


was using my vaio vpcz13v9e with a samsung mmcre28g 256GB (4x64GB in RAID0), suddenly system (win7 pro x64) hang, no BSOD was show...nothing, except fan was working hard, few minutes later i used power button to restart the system, and then i've got intel rapid technology's menu (see picture attached) with 1 of disk volumes incompatible, i tried to google this issue, but no info! i really don't know what to do, as i don't have recovery discs. I just an answer is it possible to fix somehow(update IRT ROM version somehow or else)? i need my data urgently, please advise.


intel rapid technology rom, see screenshot attached:

video of boot procces:

http://imageshack.us/clip/my-videos/689/wmm.mp4/ http://imageshack.us/clip/my-videos/689/wmm.mp4/

0 Kudos
6 Replies

200 views and no reply/solution. i love you intel

0 Kudos

Hi ar001, I am not familiar with the "Incompatible" message, but if the drive itself is OK (data is still good), you might want to take a look at my thread about restoring RAID descriptors:

/thread/18291 http://communities.intel.com/thread/18291

Good luck!

0 Kudos

Faulty SSD and being in RAID 0 you should know any data on that array is gone.

Do RAID 5 if you don't want that to happen again.

0 Kudos


This is an Intel enthusiast forum and not a lot people know data recovery. You question regards a Censorship and Virus VAIO with Samsung hardware. Part of me feels you got what you deserved for supporting the Censorship and Virus Company once known as Sony.

As Peter stated your data may be gone. If the drive is still good (the fact it reports the correct size implies this) and the crash is caused by running RTS 9.0 – 10.1 which has a known bugs that cause similar issues the data maybe recoverable.

Tools needed:

Desktop with 5+ SATA

R-Studio Technician Edition 4.0 or newer (Network edition 3.5 on TPB may work I do not know if it correctly supports RAID Virtualization, the app is well worth the $900 license fee for the latest Technician Ed.)

Windows Server or NT40. (MS usually has 90 day self destructing trial available for download.)


Install server to a donor drive with enough space for your data, on stat port 1 in AHCI mode.

Disable volume automount. (Which requires server; XP/ Vista / 7 does not support that function)

Install R-studio.

Installed drives in the same order as on the laptop and make sure the donor is the boot drive.

Create a virtual RAID 0 in R-Studio with reverse file system and 128K forward 0 parity data pattern. Make sure the order is the same as in your screen shot. R-s will show SNs.

Do a full scan.

If you are luck you will get 2 green files systems. If you get two files systems get a second laptop donor drive would be good, if not do a conventional file recovery to the first drive. Note if it shows no errors you may want to use the image raid function to a second drive.

If you get two green files systems set up two partitions on the donor a 128MB primary and a second using the rest of the space. Recover the first green files system starting at 1MB to the first partition. And the second files system to the second partition. If you see more green files system(s) near the end of the drive it's probably the recovery partition. Install donor LT drive in VAIO and boot to 7 CD to do a boot repair.

If this is too complex and your data is worth it to you take it to a professional data recovery guru. If the data is losable call Censorship and demand a replacement drive and recovery DVDs.

0 Kudos

Hi ar001,

I have the same Sony model and the same problem. Sony "repaired" four times, but the system crashes again after a while. Raid driver does not allow me to change Raid configuration as PeterUK suggested. First repair was done in authorized local service including change of all SSD. Then three more "repairs" by Sony's European Central Service, each time the laptop was repaired by installing the original software. The dealer I bought the device from can't repair the device by himself and does not want to give me my money back, because Sony does not accept installation of original software as a repair of a defective device. Now after four times going through the official repair procedure and a couple more installations of the software by myself, each time with total loss of data, I started legal actions. In some other forums I read about problems of IRST - Option ROM - I am not an expert, nor will I become an expert in this topic. I am a user who needs a reliable machine and spent a huge amount of money on a so called "professional" laptop. Such reaction of Sony's customer complaints management is just not acceptable.

I am happy to hear of more people with the same problem. Thx

0 Kudos

Thanks everybody for the helpful posts. A few years have passed since the first message in this thread but it seems that this kind of problem persists.

My problem is similar to some of the above described but differs in some key aspects. Maybe someone can have some clue to the real cause of this issue. At the same time, I hope my experience can be of help to someone, although I am not sure to have solved the issue definitely.


I have a Sony VAIO VPCZ13V9E with Windows 7 Pro (with all the MS updates) installed in a 256GB RAID0 volume built from four Samsung MMCRE28G SSD, 64GB drives mounted on a single board. The RAID Controller is:



Intel ICH8M-E/ICH9M-E/5 Series SATA RAID Controller.


Date: 03-03-2010



The problem description and my apparently successful attempts to solve it can be found below, followed by a few questions that some of you may be so kind as to reply.


The system started reporting one of the drives in the RAID volume as Failed at startup and poping-up systematic warnings of the Intel RST (IRST) software in Windows. But no data has ever been lost, no files corrupted. However, the system (mainly disk access) became slow and frequently hung when shutting down.

I run several times the Sony VAIO Care Diagnostic Tools to analyze the disks which passed all the tests; so, I used the available tools in the IRST to return the status of the disk to Normal. It worked for a few days without problem but then the issue manifested again. Since I had a recent Windows Image Backup saved in an external USB disk and a System Repair Disk (DVD), I decided to recover the system from these backups using the Windows Recovery tools. Before that, I made a fresh backup of all my data in the disk, reset the state of the faulty disk to Normal (this is important, otherwise the disk remains in the faulty state after recovery), and then reboot the system from the System Repair DVD and chose the option "Restore the computer using a System Image created earlier"; after selecting the System Image to use, I checked the option "Format and repartition disks". Although the operation was successful, after the recovery process the system remained slow and after a few days the Failed drive status reappeared.

Notes of caution: some system recovery operations require de-activating anti-virus software; is also advisable to switch off the wireless network.

Additional note: the option of removing the RAID and using the disks as non-RAID did not work since recovery from the Image Backup required more that 100GB of space and none of the individual drives could accommodate it; as such, Windows fails to recover the system from the image to the non-RAID disks. I believe this problem can be circumvented with some of the disk management tools mentioned in above messages in this forum but I did not take that approach.

My last attempt to solve this issue consisted in:

- Delete all the drives from the RAID volume

- Eliminate the RAID0 volume

- Re-create a RAID0 volume (I named it differently from the original, although it may not be relevant)

- Recovered the system using the System Repair Disk and Windows Image Backup as described above.

The system is now running OK and much faster than previously; it seems to be totally normal but I am afraid that the error may reappear one of these days...

My main question are:

1. Is this a result of a bug in the Intel RST driver which is reporting a non-existing failure?

2. Should I install the most recent version of 28-Aug-2015) of the Intel Rapid Storage Technology RAID, which is available from Intel? Or is there any risk of things going wrong with the RAID after this update?

3. Is it a hardware, SSD drive problem and I should replace the disk array?


0 Kudos