Community
cancel
Showing results for 
Search instead for 
Did you mean: 
254 Views

OneAPI windows install with silent option

Jump to solution

Does the silent option still work?

 

This still fails in my windows docker container and appears to still bring up a gui when running by hand.

RUN w_BaseKit_p_2021.3.0.3221.exe -s -a --silent --eula accept

 

0 Kudos
1 Solution
ArpanB_Intel
Moderator
167 Views

Anthony, we tested out the silent installation ourselves.


We were not able to replicate your issue and the silent installation was successful on Windows for Intel® oneAPI Base Toolkit on our end. Please confirm whether your toolkit is a local installer(offline) or an online toolkit(size in few megabytes). Also, check whether your system is meeting the prerequisites set for the product from the link we had shared earlier with you.


View solution in original post

4 Replies
ArpanB_Intel
Moderator
222 Views

Hi Anthony, please follow the below steps for a non-interactive installation:


  • Go to the directory first where the installer is located
  • Run the following command:

w_[Toolkit Name]Kit_[version]_offline.exe -s -a --silent --eula accept

  • Once the installation is complete, verify that the toolkit is installed in the default directory: C:\Program Files (x86)\Intel\oneAPI

If you are using Intel GPU, you will need to install the GPU drivers separately.


197 Views

I tried with the offline installer per your instructions and get the following error:

cmd /S /C w_BaseKit_p_2021.3.0.3221_offline.exe -s -a --silent --eula accept' returned a non-zero code: 1001
 
ArpanB_Intel
Moderator
185 Views

Anthony, could you confirm whether your system matches the prerequisites on Windows, Please click here: https://software.intel.com/content/www/us/en/develop/documentation/installation-guide-for-intel-onea..., to verify. Meanwhile, we will test this issue out ourselves and share our findings.


ArpanB_Intel
Moderator
168 Views

Anthony, we tested out the silent installation ourselves.


We were not able to replicate your issue and the silent installation was successful on Windows for Intel® oneAPI Base Toolkit on our end. Please confirm whether your toolkit is a local installer(offline) or an online toolkit(size in few megabytes). Also, check whether your system is meeting the prerequisites set for the product from the link we had shared earlier with you.


View solution in original post

Reply