Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jpharr
Novice
315 Views

Yum installation of OneMKL results in conflict error

Jump to solution

Hello,

I am working with a CentOS7-based Singularity container where I install OneMKL following these instructions: https://software.intel.com/content/www/us/en/develop/articles/installing-intel-oneapi-toolkits-via-y...

After adding the OneAPI repository to /etc/yum.repos.d, I run:

export MKL_VERSION=2021.1.1
yum -y install intel-oneapi-mkl-${MKL_VERSION}.x86_64

Previously this completed without errors, but now runs into the following conflict error:

---> Package intel-oneapi-openmp-common-2021.1.2.noarch 0:2021.1.2-266 will be installed
--> Processing Conflict: intel-oneapi-common-vars-2021.2.0-195.noarch conflicts intel-oneapi-common-licensing < 2021.2.0
--> Finished Dependency Resolution
Error: intel-oneapi-common-vars conflicts with intel-oneapi-common-licensing-2021.1.1-2021.1.1-60.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 The source of the issue therefore relates to intel-oneapi-common-licensing:

dependency: intel-oneapi-common-licensing
   provider: intel-oneapi-common-licensing-2021.1.1.noarch 2021.1.1-60
   provider: intel-oneapi-common-licensing.noarch 2021.2.0-195

Any thoughts on what one would need to do to resolve this? Unfortunately using --skip-broken is impossible as it prevents installation of several key components.

Many thanks in advance for your help!

Labels (1)
0 Kudos
1 Solution
jpharr
Novice
196 Views

Further to my previous response,

I investigated a little further and found that if I swap the OS to CentOS8 without making other changes to the recipe, that is:

Bootstrap: docker
From: centos:8

... then the installation works.

Best wishes,

Jesse

View solution in original post

3 Replies
ArpanB_Intel
Moderator
237 Views

Hi Jesse, could you please confirm whether you have multiple versions of Intel® oneAPI installed on your system or not? Please note that having multiple versions of the product on the same system might not work. From the error message you had shared, we believe that you might have 2021.1.1 version of the compiler already installed on the system.


jpharr
Novice
229 Views

Hi,

Thanks for the reply. I can confirm that there are no other versions of Intel® oneAPI installed. I have attached a minimal Singularity container definition file + associated .repo file for reproducing the error, which appears when building a new container.

As .def and .repo file extensions aren't supported by the forum, I have added these as .txt files (to use them, they will need to be renamed to mkl_conflict.def and oneAPI.repo).

On a system with Singularity installed, the container can be built with:

sudo singularity build mkl_conflict.sif mkl_conflict.def

 For ease of viewing, I will also write out the contents of the files.

oneAPI.repo:

[oneAPI]
name=Intel(R) oneAPI repository
baseurl=https://yum.repos.intel.com/oneapi
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS.PUB

 mkl_conflict.def:

Bootstrap: docker
From: centos:7

%files

  oneAPI.repo /etc/yum.repos.d

%post

  yum -y update

  export MKL_VERSION=2021.1.1
  yum -y install intel-oneapi-mkl-${MKL_VERSION}.x86_64

I have also attempted this variation to no avail:

Bootstrap: library
From: centos:7.7

Cleaning the Singularity cache had no impact on the overall result and the problem has also been replicated by colleagues. We suspect there may be a recent problem with the repository, as previously there was no issue.

Many thanks,

Jesse

jpharr
Novice
197 Views

Further to my previous response,

I investigated a little further and found that if I swap the OS to CentOS8 without making other changes to the recipe, that is:

Bootstrap: docker
From: centos:8

... then the installation works.

Best wishes,

Jesse

View solution in original post

Reply