Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yanzhou
Beginner
453 Views

oneAPI Installation failed 'no Qt platform plugin'

Jump to solution

Hi,

I downloaded oneAPI BaseKit but every time the installation ended up with the error of 'This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix the problem. Available platform plugins are: minimal, offscreen, windows.'

Could anyone help to sort this?

Thanks very much!

Yan

0 Kudos
1 Solution
Nikky_P_Intel
Moderator
434 Views

Hello Yan,


This issue is mostly related to an application using a system path. However, we would like to confirm if you have installed any new software recently or modified your PATH (shortly before this issue began)?


If Yes, than please remove the folder from your PATH.


Follow below steps to remove the path:

1) Open cmd and type echo %QT_PLUGIN_PATH% if it's not empty then delete it.


2) Open cmd and type echo %PATH% and press enter. You'll see a list separated by ; of folder paths. Go line by line and make sure they do not point to a folder that contains a platforms folder that has qwindows.dll in it. If you find such a path edit the PATH variable and remove it.



View solution in original post

3 Replies
Nikky_P_Intel
Moderator
435 Views

Hello Yan,


This issue is mostly related to an application using a system path. However, we would like to confirm if you have installed any new software recently or modified your PATH (shortly before this issue began)?


If Yes, than please remove the folder from your PATH.


Follow below steps to remove the path:

1) Open cmd and type echo %QT_PLUGIN_PATH% if it's not empty then delete it.


2) Open cmd and type echo %PATH% and press enter. You'll see a list separated by ; of folder paths. Go line by line and make sure they do not point to a folder that contains a platforms folder that has qwindows.dll in it. If you find such a path edit the PATH variable and remove it.



View solution in original post

yanzhou
Beginner
428 Views

Hi,

Thanks very much for your reply. I have done as you instructed and indeed there was a path created recently when I installed another software. I removed it and the problem was solved! 

Regards

Yan

Nikky_P_Intel
Moderator
423 Views

We are glad that your issue is resolved. We are closing this thread now if you have any other queries please open another thread and we will be happy to help you.


Reply