Community
cancel
Showing results for 
Search instead for 
Did you mean: 
julochev
Beginner
595 Views

oneAPI installation fails

Jump to solution

During instalation of oneAPI Toolkit I got this error mesage "Installer failed with error Sqlite SQL execution failed." However, sqlite is installed. Any idea what is happening?

0 Kudos
1 Solution
Soumya_M_Intel
Moderator
256 Views

Hi julochev,


Thanks for your patience while we were waiting to hear back from the concerned team. The below-given might be the reasons for the failure. Please go through them to resolve the issue.


  • Corrupted installer database - make sure there is no file packagemanager.db in $home/intel/installercache (user install) or /var/intel/installercache (root install) before installation


  • No free space to create (or update) database - check space in $home/intel/installercache (user install) or /var/intel/installercache (root install)


  • No write permissions in the places above.


SQLite installed should not affect installation because the installer uses its own statically linked version.


However, if the issue still persists, please send a full set of log files, located at: /tmp/<user_name>/intel_oneapi_installer


Regards,

Soumya


View solution in original post

15 Replies
Soumya_M_Intel
Moderator
551 Views

Hi julochev,


Thanks for posting your concern on the forum. Could you please let me know the complete name and version of the operating system? It would provide us a better understanding of the issue.


Regards,

Soumya


julochev
Beginner
547 Views
Hi Soumya,  Thanks for your quick answer.
 
I'm trying to install oneAPI toolkit as a user in a cluster with linux OS
 
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"
 
I hope it helps,
 
Cheers
julochev
Beginner
546 Views

Linux kernel version

3.10.0-693.5.2.el7.x86_64

Soumya_M_Intel
Moderator
526 Views

Hi julochev,


Thanks for the details. Based on the information, we would be requiring a few more details.


  • The complete screenshot of the  Intel® oneAPI AI Analytics Toolkit installer along with the error message
  • The installation log of the Intel® oneAPI AI Analytics Toolkit.
  • The version of SQLite i.e. currently installed. And is it a clean installation?


The above details would allow us to check further on the issue.


Regards,

Soumya


julochev
Beginner
511 Views

Dear Soumya,

 

Thanks for your quick answer.

This is what I get when trying to install oneAPI Base toolkit:

 

$ ./l_BaseKit_p_2021.3.0.3219.sh
Extract l_BaseKit_p_2021.3.0.3219 to /hpcfs/home/tmdc-redcca/l_BaseKit_p_2021.3.0.3219...
[#####################################################################################################################################################################################################]
Extract l_BaseKit_p_2021.3.0.3219 completed!
Could not detect graphical display, installation will continue in console mode. If you aim to launch the installer graphical user interface under root try `xhost si:localuser:root` command and then restart the application.
Checking system requirements...
Done.
Wait while the installer is preparing...
Done.
Launching the installer...
Installer failed with error Sqlite SQL execution failed.
Remove extracted files: /hpcfs/home/tmdc-redcca/l_BaseKit_p_2021.3.0.3219...

 

sqlite3 --version
3.7.17 2013-05-20 00:56:22 118a3b35693b134d56ebd780123b7fd6f1497668

 

 

 

Soumya_M_Intel
Moderator
474 Views

Hi julochev,


Thanks for providing the information. We are currently checking on the concern with our internal team. We will get back to you as soon as possible.


Regards,

Soumya


ChrisB_Intel
Moderator
466 Views

julochev,


Do you have the UI components of the OS installed? It looks like you maybe running command line only?


Thanks

Chris



julochev
Beginner
454 Views

Hi ChrisB,

 

Sorry for the late answer.  Yes, I'm running commands line only. Could the probem be related with it?

 

Cheers,

ChrisB_Intel
Moderator
395 Views

I am trying to find an comprehensive list of which components are required. My expectation is X11, but I am waiting to hear confirmation.


Thanks

Chris



Tess
Beginner
256 Views

Hello,

 

Any further developments on this? I am trying to install in silent mode on an HPC cluster that has sqlite in PATH and am getting a similar error.

Thanks!
Tess

Soumya_M_Intel
Moderator
257 Views

Hi julochev,


Thanks for your patience while we were waiting to hear back from the concerned team. The below-given might be the reasons for the failure. Please go through them to resolve the issue.


  • Corrupted installer database - make sure there is no file packagemanager.db in $home/intel/installercache (user install) or /var/intel/installercache (root install) before installation


  • No free space to create (or update) database - check space in $home/intel/installercache (user install) or /var/intel/installercache (root install)


  • No write permissions in the places above.


SQLite installed should not affect installation because the installer uses its own statically linked version.


However, if the issue still persists, please send a full set of log files, located at: /tmp/<user_name>/intel_oneapi_installer


Regards,

Soumya


View solution in original post

Tess
Beginner
242 Views

Hi Soumya,

 

Thanks for helping troubleshoot. I can confirm that I do not have a corrupted database -- I removed the intel folder prior to installation. I also have plenty of space in my $TMPDIR and home directory (no limits are placed on these directories by the cluster owners). I'm attaching my logfiles which I ran with chmod 666 but the problems persit with chmod 777 on the .sh file as well.

 

Thanks again for your time!

Tess

Anna_M_Intel
Employee
189 Views

Hi Tess,

Logs say creating database ended with I/O error got from operating system. 

Such issues may occur if data protection is enabled or if database file became locked.

Is directory /home/gridsan/tsmidt  shared between cluster nodes?

Please try the following (separately and in combination):

1) remove sqlite from path

2) redirect installer cache by redefining $HOME environment variable (it will also affect installation directory location, but it can be changed separately)

 

Soumya_M_Intel
Moderator
127 Views

Hi julochev,


I assume that your issue is resolved. However, if you need any additional information, please post a new question as this thread will no longer be monitored by Intel®. 


Have a nice day ahead.


Regards,

Soumya


Soumya_M_Intel
Moderator
125 Views

Hi Tess,


If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel®. Have a nice day ahead.


Regards,

Soumya


Reply