Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
874 Views

BIOS error "Major - 146 - PCI out of resource" on S2600GZ

Hello,

I've recently installed a PCIe card that needs 8 GB of BAR2 memory space.

My system seems to be unable to provide the card with those resources (computer boots directly in bios with error "Major - 146 - PCI out of resource").

I've enabled "Memory Mapped I/O above 4GB" and tried toggling "Maximize Memory below 4GB" but to no avail.

I know the card works since it boots on my Desktop Xeon machine (Precision WorkStation T3500).

Also, the card boots on the S2600GZ when I reduce the BAR2 size.

In my case, I need the whole 8 GB.

Is there a way to get this to work?

Thanks

0 Kudos
2 Replies
Highlighted
Community Manager

Re: BIOS error "Major - 146 - PCI out of resource" on S2600GZ

Dear pavelz,

Greetings!!!

Change the bios settings of Memory Mapping.

Go to BIOS => Advanced => PCI Configuration =>

Maximize Memory below 4GB Disabled

Memory Mapped I/O above 4 GB Enabled

Memory Mapped I/O Size

I hope this settings will solve your problem.

with regards,

C.Raja

Highlighted
Community Manager

Re: BIOS error "Major - 146 - PCI out of resource" on S2600GZ

Dear Raja,

Thanks for the clarifications!

I had to update my BIOS to the latest version to get the Memory Mapped I/O Size option.

This solved my problem.

However, I've got another problem now, and I was wondering if you could help.

Is there a way to make the system boot even if there are not enough resources for one of the devices, i.e. disregard error 146?

What happened is that during a test, I set a large chunk of memory (8Gb) as non-prefetchable for a device. Now looking at PCI specs, I see that non-prefetchable memory is limited to 32-bit. I need to boot in my system in order to revert those changes.

Thanks in advance,

Pavel

0 Kudos