Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,209 Views

Disable c-state in Intel s3420GPC

We are having problems with a server which has Hyper-V installed on Win 2008 R2 x64; it would just give a BSOD and then reboot randomly. As we have purchased a few of these servers and have had them a few years already the BSOD has been a consistent occurence on all of them and the Hyper-V just seems to make the problem worse.

I then tried to make sense of updating the BIOS (hoping it will fix the issue) but the Intel documentation is so confusing (it refers to the booting into EFI shell and running the .nsh scripts but there are no such scripts with the EFI downloads).

For now I have given up in updating the BIOS but no that the c-state of the processor could be responsible for this (on one server Microsoft assisted and it seemed like it fix the issue by making a registry change in Windows). That said, I cannot figure out where to disable the c- state for this motherboard (Intel s3420GPC) in the BIOS. I believe this BSOD issue is related to http://deinoscloud.wordpress.com/2009/10/22/disable-c-state-why-that/ Disable C-State, Why That? « DeinosCloud and http://support.microsoft.com/kb/974598 You receive a "Stop 0x0000007E" error on the first restart after you enable Hyper-V on a Windows Server 2008 R2-based computer

0 Kudos
1 Reply
Edward_Z_Intel
Employee
61 Views

1. Download the latest firmware package here: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21517 http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21517. Extract it to a USB key and run startup.nsh from EFI shell. Note that the USB key must be formatted in FAT or FAT32 partition.

2. Go to Advanced => Processor Configuration menu in BIOS and try to disable "Processor C3" and "Processor C6". You may also try to disable "Enhanced Intel SpeedStep Tech".

Reply