Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,602 Views

LSI SAS 3000 (4-port 1064e) firmware update?

Hi,

Can somebody tell me how to upgrade the onboard SAS controller firmware of an S5000PSLSASR board?

I have read the instructions:

================

 

Update Instructions

 

================

 

Warning: If AXXSASIOMOD, or AXX4SASMOD is installed in SR2600URLX, SR1600UR, SR1625UR, SR2500ALLX, SR1500ALSAS, or SR1560SFHS system

 

- SAS controller on midplane/backplane must be disabled in BIOS Setup when updating SAS IO module firmware

 

- SAS IO module must be disabled in BIOS Setup when updating SAS controller on midplane/backplane firmware

Warning: If any add-in controller firmware is to be upgraded, the onboard controller should be DISABLED in BIOS, and each add-in controller should be done individually by type (For example: two add-in cards with the same type is fine).

Warning: If an Intel or LSI SAS HBA (add-in card) is installed in the system, it should be removed before updating onboard SAS controller, active SAS midlane/backplane, or ROMB card. If not removed, firmware on the HBA card will be erased. Once the onboard controller is updated, only one add-in controller should be updated at a time.

 

1. Unzip all of the files from the zip package onto USB key, maintaining the directory structure. Please make sure that the USB key is fully compatible with the EFI version on your motherboard. Some incompatible versions may prevent USB key working normally.

2. Boot to the EFI shell

 

- Press 'F2' during POSt to enter BIOS Setup

 

- Select Boot Manager -> EFI Shell

3. Change drive and directory location to where you unzipped the package by typing the following commands:

 

fs0:

 

cd

Note: You can always get a list of files and sub-directories in the current directory by typing 'dir' command.

 

Instead of 'fs0: you may need to type 'fs1:' or 'fs2:', etc. depending on your drive configuration and removable media type.

 

4. Type in the name of the batch file that matches your board model and press :

5. Reboot and confirm the OpROM/FW versions (depending on mode) and drives listed.

----------------

It does not work for me!

If I boot EFI no UBS Key/Stick is recognised.

The USB stick is FAT32 formatted.

Do I have to format it a special way to let EFI recognise the USB Stick?

There is no information on that in the readme file.

Thank in advance for your help!

0 Kudos
3 Replies
Highlighted
Employee
40 Views

Re: LSI SAS 3000 (4-port 1064e) firmware update?

FAT32 should be OK. With your USB key plugged, type "map -r" in EFI shell, what do you get?

For more information about EFI shell, see http://www.intel.com/support/motherboards/server/sb/CS-028743.htm Server Products - Extensible Firmware Interface (EFI) basic instructions

0 Kudos
Highlighted
Community Manager
40 Views

Re: LSI SAS 3000 (4-port 1064e) firmware update?

Well Edward I have tried another USB Stick and BINGO it worked right away :-)

I think some usb sticks are not compatible.

But thanks for your help!!!!

The thing is now when I want to do a fresh install of Windows 2008 R2 I have to give the right driver /message/193207# 193207 LSI SAS 3000 (4-port 1064e) when pressing F6 but this is not listed when I scroll in the list.

The driver was downloaded at Intel's website for the correct board S5000PSLSASR

Do I have to open another thread for this?

0 Kudos
Highlighted
Employee
40 Views

Re: LSI SAS 3000 (4-port 1064e) firmware update?

0 Kudos