Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4853 Discussions

Lost ipstor.conf on a Intel SS4000-E NAS


Hi all,

I've problems with an Intel SS4000-e NAS

I'm using firmware 1.4

My problem is, that I lost the /usr/local/ipstor/etc/storage_name/ipstor.conf file, where the sector boarders for the /dev/vbdi(n) devices are stored.

So the tool /usr/local/ipstor/bin/ipstormount can't find the chunks needed for creating the vbdi devices and mounting the XFS filesystems.

My /dev/md1 RADI5 system is still healthy. Is there a way to scan, extract or find the sector borders within the /dev/md1 device to write them in a new ipstor.conf file?

Would be very helpfull if you can provide some information.



Corrected Model Number of NAS

0 Kudos
2 Replies


The ipstor.conf file is created when the array is created at initialization. A fresh install without hard drives does not have the /sorage system name folder or the ipstor.conf file.



0 Kudos

Hi John,

I had a already setup and running system with 4 disks and a RAID5 configuration.

But once after power on it had blinking LEDs and didin't come up.

So I bootet with the emergency system from flash (with no disks plugged in). There I found out that 2 of the 4 drives get unreliable, sometimes one of them are not shown after bootup. But after plugging in the drives a second time or a third time there where recogniced correct. And I was able to start the /dev/md1 RAID5 device in a "healthy" state with 3 of 4 disks.

First I tried to get the operating system on the /dev/md0 RAID 1 device mountet and see if I can start a chroot environtment to get the data partitions mountet to do a backup. But I didn't know to do because I don't know which skript or commands have to be run in which order.

At one point I tried to do a fs2chk on the /dev/md0 (operating system) and it found many errors. I fixed them, but after the 3rd or 4th fs2chk run the filesystem was gone completle.

To get the operating system back I plugged a factory new harddisk in the system and did a fresh install (initialization) only with this one new disk.

As next I replaced one of the two shaky drives with this new disks, did a mdamd rebuild of /dev/md1 so that the RAID5 was everytime in a healthy state.

Then did a rebuild/synchronisation for the /dev/md0 to get the operating system back to all drives

Then I replaced the second shaky drive with a new one, did the RAID5 rebuild.

The state at this point is:

A a healthy /dev/md1 RAID5 data partition system.

A fresh operation system on /dev/md0 RAID1 without the new initialized /usr/local/ipstor/etc/frabastorage/ipstor.conf file. frabastorage is the name I gave my storage system.

The problem is of course that within this ipstor.conf file all information about the original (old) frabastorage system are lost. The most important and in this case critical data are the sector boarders of the "kvbdi IP STOR virtual volume manger" logical volumes which are distributed to the RAID5 physical partition.

For each share you create in the web interface a new logical volume (and logical device (dev/vbdi(n) ) is created on the RAID5 partition. And the start and end sectors for this new logical volume are saved in the ipstor.conf.

But I don't have the old ipstor.conf with this information.

I need some tool which can scan for the kvbi volume start and end boarders. the IP STOR system uses XFS as filesystem, perhaps a tool which can scan for XFS filesystem signaturs would be a solution.

To research how the falconstor "IP STOR" firmware is working I set up a "research system" with two harddisk where I can play (research) everything without frear of losing data.

Up to know I never bootet the NAS with the 4 disk setup, only with the flash rescue system. I never did a reinitialzation of the 4 disks (which of course would delete all data).

I hope my explanation could be understand some how.

PS: I contacted about support, but they told me, that I should talk to intel, because it's an OEM product. There have a Level3 OEM support division in USA, but the product is EndOfLive since some years, so the in no case would give me support.

I'm also trying to get support from intel, but I'm didn't come very far up to know.



0 Kudos