Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yitzh2
Beginner
308 Views

S1200S UEFI boot - boot option gets deleted

I use a UEFI file on my drive, and defined that file as the UEFI boot option.

This works well.

If, for any reason, the drive is not present (even temporarily) - that boot option is erased from the BIOS, and the system falls into some default from now on.

(using the latest BIOS version 01.0042)

0 Kudos
18 Replies
SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Can you please provide us the exact model of your Intel(R) server board? We need this information so we can check if you are running the correct BIOS if possible please provide us a screenshot of your BIOS screen. 

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

For firmware updates and troubleshooting tips, visit :https://intel.com/support/serverbios

yitzh2
Beginner
59 Views

Sergio, The MB I'm using is S1200SPLR, inside our own casing. See attached image of the BIOS screen. Thanks, Yair [cid:image001.jpg@01D58F0D.03896360]
SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Thank you for the information.

 

Please try to perform a BIOS recovery, by following these steps:

 

1. Turn off the system.

2. For safety, remove the Alternating Current (AC) power cords.

3. Remove the system top cover.

4. Move the "BIOS Recovery" jumper from the default operating position (covering pins 1 and 2) to the BIOS Recovery position (covering pins 2 and 3). https://www.intel.com/content/dam/support/us/en/documents/server-products/S1200SP_TPS_AllSKU.PDF page 85.

5. Re-install the system top cover and re-attach the AC power cords.

6. Power on the system.

7. The system will automatically boot the Extensible Firmware Interface (EFI) shell. Hence, update the BIOS using the standard BIOS update instructions.

8. After the BIOS update has successfully completed, power off the system. For safety, remove the AC power cords from the system.

9. Remove the system top cover.

10. Move the "BIOS Recovery" jumper back to the default operating position (covering pins 1 and 2).

11. Re-install the system top cover and re-attach the AC power cords.

12. Power on the system and access the <F2> BIOS Setup utility.

13. Configure the desired, customized BIOS settings.

14. Hit the <F10> key to save and exit the utility.

 

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

yitzh2
Beginner
59 Views

Sergio,

I have gone through the update process.

Then, defined the EFI file entry, named it a name, booted - all well.

Then removed the disk, rebooted - the system went into EFI shell as expected.

Put back the disk and rebooted - the system went (unexpectedly) into EFI shell.

The BIOS no longer has the entry I've defined.

Yair

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Thank you for the information.

 

Please try to clear the CMOS of your system, refer to the Technical Product Specification on page 86

 

https://www.intel.com/content/dam/support/us/en/documents/server-products/S1200SP_TPS_AllSKU.PDF

 

Additionally, please load the BIOS default settings.

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

yitzh2
Beginner
59 Views

Hi,

Went through required steps – same results.

Notice that the PDF does not shows a "CMOS clear" process – only "clear passwords".

Still – did that, as well as loaded BIOS defaults.

My EFI option is deleted from memory if the disk is disconnected and reconnected.

 

Yair

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Thank you for the information.

 

We are going to check with our upper-level support in regards to your case.

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

For firmware updates and troubleshooting tips, visit :https://intel.com/support/serverbios

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Thank you for contacting Intel Customer Support.

 

We have replicated your case on our end. And we do see that the Windows Boot loader entry is removed but you should be able to boot to the hard drive directly.

 

Let us know if you need anything else. 

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Thank you for contacting Intel Customer Support.

 

We are following your question and we would like to know if you need more help.

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

yitzh2
Beginner
59 Views

Sergio, Your solution is not workable for me, since the once the entry gets erased – the BIOS will default to “startup.ncf”, and delay for 5 seconds until it loads it. These 5 seconds are precious in my environment, and I would like to avoid it at any cost. I cannot see how Intel had recognized the issue, but will not attempt to fix it? Thanks, Yair
SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Allow me to check with our upper-level support again and I will share your feedback with them.

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

 

Lewis-H
New Contributor I
59 Views

Have tried these steps? These steps worked in my dell laptop. Not sure about other brand laptops.

Steps are provided below:

  1. Boot mode should be selected as UEFI (Not Legacy)
  2. Secure Boot set to Off. ...
  3. Go to the 'Boot' tab in the BIOS and select Add Boot option.
  4. A new window will appear with 'blank' boot option name.
  5. Name it "CD/DVD/CD-RW Drive"
  6. Press < F10 > key to save settings and restart.
  7. The system will restart.

 

Regards,

Lewis

 

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

First, we would like to apologize for the delay in our response. 

 

We have followed those steps and we do not see any delays and can send us a video with the delay?

 

Is this a delay happening during the system reboot?

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

For firmware updates and troubleshooting tips, visit :https://intel.com/support/serverbios

yitzh2
Beginner
59 Views

Sergio,

I'll repeat the setup to make the baseline right:

1. I'm in UEFI mode

2. I created a named boot option, with a specific UEFI boot file on the disk

3. This boots well (and fast)

4. I now remove the disk, reboot , and re-connect the same disk.

5. The system no longer has the selected boot entry (it got deleted in step 4), so it loads the UEFI shell by default.

6. The shell has a 5 seconds delay, after which it loads the file "Startup.nsh".

The delay I was complaining about is the one in step 5.

Yair

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

Can you please provide us a video with the delay, so we can provide it to our upper-level support?  

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

I am following your case, and we were wondering if you were able to take the video with the delay.

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

 

yitzh2
Beginner
59 Views

Sergio See attached video. Thanks, Yair
SergioS_Intel
Moderator
59 Views

Hello yitzh2,

 

We just sent you a private message requesting some additional information.

 

Best regards,

Sergio S.

Intel Customer Support Technician

A Contingent Worker at Intel

 

Reply