Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4617 Discussions

S1200V3RPL: "bmclibinitialized returned failed" after BMC update to 01.12.7499


I updated an S1200V3RPL board to the latest BMC release 1.12.7499 via UEFI using the software provided by this link: Intel® Download Center [1]

After the update, I wanted to change the SDR. Because [1] did not contain an SDR update utility, I tried to re-use the UEFI utility updFRUSDR.nsh provided by this link: Intel® Download Center [2]. However, the SDR update failed with a "bmclibinitialized returned failed" error after loading "ipmi.efi". Trying to downgrade the BMC firmware back to the previous version 01.12.6784 (using updBMC.nsh from [2]) again failed with the same error.

I could downgrade the BMC firmware to version 01.12.6784 by writing BMC_i_0112r6784.bin from [2| with the fwpiaupd.efi utility from [1]. However, this had no effect on the aforementioned error, i.e. re-running updFRUSDR.nsh from [2| still failed with the same error.

How do I downgrade properly to a BMC firmware where updFRUSDR.nsh from [2] can run successfully? If this is not possible, is there another way to write the SDR with the 01.12.7499 BMC firmware applied?

Thank you,


0 Kudos
2 Replies


Although we have not seen the "bmclibinitialized returned failed" error, because of the steps you have tried out, we recommend the following alternative ones:

1. Updated the complete [BIOS and firmware, which includes BMC, ME, FRU and SDR] package to 02.02.0005:

1.2. Unzip the contents of the update package and copy all files to a folder on a bootable USB flash drive.

1.2. Insert the USB flash drive to any available USB port on the server system.

1.3. Boot the Server to the EFI shell. This can be accessed via the BIOS setup utility during POST.

1.4. Run the command "fs0:" to change folders to the USB flash drive.


- The USB flash drive may also mount to fs1: depending on other installed devices.

- Run the command "map -r" in the EFI shell, if needed, to mount the USB flash drive. The number of "fs# " is dependent on the result of command "map -r".

1.5. Run the command "Startup.nsh" to start updating all the firmware and BIOS updates. Follow the on-screen instructions. When you are presented with the 5 options introduced by "Select the function you desire to perform", see to it that you choose 3 ("Update both..."). Again, follow the on-screen instructions.

1.6. Reboot the system into BIOS by pressing F2 during POST and ensure BIOS/firmware was successfully done:

BIOS : R02.02.0005

ME : R03.00.05.128

BMC : 1.12.6784

FRUSDR : 1.07

2. Once the BIOS/firmware is updated, please, re-attempt to update to the latest 01.12.7499 BMC once more should you consider your server really needs it:

The Release Notes for this most current BMC version is found here:

0 Kudos

Thanks for the reply.

I had already performed the updates to 02.02.0005 before I did the update to BMC version 01.12.7499. Now *after* the update to BMC version 01.12.7499 (which was successful), I cannot run any of the updaters that you mention (referenced as [2] in my first post), including "updFRUSDR.nsh". They all fail with the "bmclibinitialized returned failed" error.

It seems that the BMC update to 01.12.7499 irreversibly changed something such that the updaters to version 02.02.0005 contained in [2] now all produce this error. The BMC is still operational though: it responds to requests from ipmitool under Linux, and I could successfully repeat writing the BMC firmware 01.12.7499.

0 Kudos