Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SF_
Beginner
2,766 Views

S2600WF0 SysCfg : set Fan PWM Offset

Hello,

we've got a couple of hundreds of Intel S2600WF0 servers. BIOS/ME/BMC/FRUSDR are all the latest:

BIOS Version Information:

-------------------------

Primary BIOS Version:... SE5C620.86B.00.01.0014.070920180847

Secondary BIOS Version:. SE5C620.86B.00.01.0014.070920180847

BIOS Boot Region:....... Primary Boot

BMC Firmware Version:

---------------------

Op Code:........... 1.60.56383BEF

ME Firmware Version:.. 04.00.04.340

SDR Version:.......... SDR Package 1.60

Baseboard Information:

----------------------

Base Board ID:..... S2600WF0

Asset Tag Name:.... Base Board Asset Tag

System Information:

----------------------

Manufacturer Name:. Intel Corporation

Product Name:...... S2600WF0

Version Number:.... ..

Chassis Information:

----------------------

Manufacturer Name:. ...............................

Chassis Type:...... Rack Mount Chassis

Asset Tag Name:.... ....................

Also have the latest SysCfg: System Configuration Utility Version 14.1 Build 21

OS: Debian 9 'Stretch' 64bit

We'd like to be able to change the Fan PWM Offset using the SysCfg utility, but it's not working:

$ sudo /usr/bin/syscfg/syscfg /bcs "" "Fan PWM Offset" 100

BIOS Variable 'Fan PWM Offset' not found

However, the fan profile can be changed:

$ sudo /usr/bin/syscfg/syscfg /bcs "" "Set fan profile" 1

Successfully Completed

If I save all the settings with sudo /usr/bin/syscfg/syscfg /s /f /b, then the resulting syscfg.INI file doesn't have anything about Fan PWM Offset, it only has the Set Fan Profile in the System Acoustic and Performance Configuration group:

[BIOS::Advanced::USB Configuration]

Device Reset Timeout=20 seconds ;Options: 10 seconds=00: 20 seconds=01: 30 seconds=02: 40 seconds=03

[BIOS::Advanced::System Acoustic and Performance Configuration]

Set Fan Profile=Performance ;Options: Performance=01: Acoustic=02

[BIOS::Security]

Front Panel Lockout=Disabled ;Options: Disabled=00: Enabled=01

Tried to insert Fan PWM Offset=100 into the [BIOS::Advanced::System Acoustic and Performance Configuration] group and the restore the syscfg.INI file with the restore option of syscfg. The utility said the restore was successful, but the Fan PWM Offset change didn't effect, the BIOS showed the old value (0). We'd like to avoid manually changing this on hundreds of servers obviously.

 

Also tried to downgrade BIOS/BMC to the previous version. With the old BIOS/BMC syscfg was able read the Fan PWM Offset value (i.e. sudo /usr/bin/syscfg/syscfg /d biossettings "Fan PWM Offset" was working), but unable to write it.

 

According to the release notes of latest BIOS the Fan PWM Offset should work with SysCfg: https://downloadmirror.intel.com/28252/eng/Release%20Notes.txt https://downloadmirror.intel.com/28252/eng/Release%20Notes.txt

See: HSD-ES:1504762466, BIOS Change for # CCB 2083[Syscfg tool]Add option to configure fan pwm offset in syscfg

How to change the fan pwm offset? Please help!

0 Kudos
11 Replies
idata
Community Manager
232 Views

Hello Szabolcsf,

Are you getting loud fans after you perform the BIOS update?

Additionally, as first troubleshooting suggestion, please try to perform a BIOS recovery downgrade to the previous BIOS https://downloadcenter.intel.com/download/27632/Intel-Server-Board-S2600WF-Family-BIOS-and-Firmware-... version.

After performing the BIOS recovery, please try to change the PWM offset again,

In case you have any additional questions, please check the https://www.intel.com/content/dam/support/us/en/documents/server-products/server-boards/Intel_Syscfg... user guide.

 

Best regards,

 

Sergio S.
SF_
Beginner
232 Views

Hi Sergio,

thanks for trying to help. When upgrading to the latest BIOS, yes, the fans are loud. But only for ~2 minutes, until the new BIOS/ME/FRUSDR is loaded. After that everything is normal. This is not the reason why we want to change the offset setting. We are doing CPU intensive computing and PSU2 is overheating (this is closer to the processors). PSU2 temperature is frequently hitting 62C which makes the servers throttle. We've done some experiments and determined that if we use Set Fan Profile=Performance and Fan PWM Offset=100 then PSU2 temperature drops by ~5-10C and the servers won't throttle. Now we just need to deploy this to a couple of hundreds of servers without manually entering the BIOS on each.

Regarding the previous BIOS and firmware versions: as I wrote, only reading the Fan PWM Offset works, but writing doesn't. Let me clarify what I mean:

$ sudo /usr/bin/syscfg/syscfg /d biossettings "Fan PWM Offset"

Fan PWM Offset

==============

Current Value : 0

-----------------

Possible Values

---------------

100 : Max

0 : Min

1 : Step

~$ sudo /usr/bin/syscfg/syscfg /bcs "" "Fan pwm offset" 1

Error: Change BIOS setting failed. It may be caused by invalid data in the switch parameters.

~$ sudo /usr/bin/syscfg/syscfg /bcs "" "Fan pwm offset" 0

Error: Change BIOS setting failed. It may be caused by invalid data in the switch parameters.

~$ sudo /usr/bin/syscfg/syscfg /bcs "" "Fan pwm offset" 100

Error: Change BIOS setting failed. It may be caused by invalid data in the switch parameters.

~$ sudo /usr/bin/syscfg/syscfg /bcs group "system acoustic and performance configuration" "Fan pwm offset" 100

Invalid invocation or entered password does not match with current password.

$ sudo /usr/bin/flashupdt/flashupdt -i

One Boot Flash Update Utility Version 14.1 Build 17

Copyright (c) 2018 Intel Corporation

System BIOS and FW Versions

BIOS Version Information:

-------------------------

Primary BIOS Version:... SE5C620.86B.00.01.0013.030920180427

Secondary BIOS Version:. SE5C620.86B.00.01.0013.030920180427

BIOS Boot Region:....... Primary Boot

BMC Firmware Version:

---------------------

Op Code:........... 1.43.91F76955

ME Firmware Version:.. 04.00.04.294

SDR Version:.......... SDR Package 1.43

Baseboard Information:

----------------------

Base Board ID:..... S2600WF0

Asset Tag Name:.... Base Board Asset Tag

System Information:

----------------------

Manufacturer Name:. Intel Corporation

Product Name:...... S2600WF0

Version Number:.... ..

Chassis Information:

----------------------

Manufacturer Name:. ...............................

Chassis Type:...... Rack Mount Chassis

Asset Tag Name:.... ....................

Successfully Completed

Relevant part of the syscfg.INI file with previous firmware versions and with latest SysCfg:

[BIOS::Advanced::System Acoustic and Performance Configuration]

Set Fan Profile=Acoustic ;Options: Performance=01: Acoustic=02

Fan PWM Offset=0 ;Options: 100=Max: 0=Min: 1=Step

Air Flow Limit=100 ;Options: 100=Max: 60=Min: 1=Step

Exit Air Temp=70 ;Options: 70=Max: 50=Min: 1=Step

Fan UCC=100 ;Options: 100=Max: 70=Min: 1=Step

This happens if I edit the Fan PWM Offset value in syscfg.INI and try to restore the file:

~$ sudo /usr/bin/syscfg/syscfg /r syscfg.INI /f /b

Restoring file syscfg.INI in progress...

"BootOrder::Hard Disk" is empty, skip this item

Failed to set "BIOS::Advanced::System Acoustic and Performance Configuration::Fan PWM Offset", "100" is an invalid value, skip this item.

Successfully Completed

So it seems the previous BIOS/firmware also had issues changing the Fan PWM Offset, that's probably why Intel tried to fix it in the latest version, but it just got worst.

idata
Community Manager
232 Views

Hello Szabolcsf,

 

 

We appreciate the additional information, we are going to check on your issue and will get back to you.

 

 

 

Best regards,

 

Sergio S.
SF_
Beginner
232 Views

Hi Sergio S.,

thanks! Is there perhaps an ETA? If you need anything else to reproduce the problem, just let me know.

idata
Community Manager
232 Views

Hello Szabolcs F,

 

 

Please refer to syscfg user guide at

 

 

https://www.intel.com/content/dam/support/us/en/documents/server-products/server-boards/Intel_Syscfg...

 

 

Page 52 shows the PWM offset entry:

 

 

Fan PWM Offset=0 ;Options: 100=Max: 0=Min: 0=Step

 

 

Within the [BIOS::System Acoustic and Performance Configuration] section.

 

 

Additionally, please provide us with a copy of .ini file.

 

 

Best regards,

 

 

Sergio S.
SF_
Beginner
232 Views

Hello,

I'm familiar with the user guide. The problem is either Syscfg or the BIOS/firmware has a bug that is preventing us from changing the Fan PWM Offset with Syscfg.

 

This is the full output of sudo /usr/bin/syscfg/syscfg /s /f /b : https://pastebin.com/6wtdc72a [INI file] ; Warning!!! Warning!!! Warning!!! ; --------------------------------- ; This - Pastebin.com

 

Notice that it doesn't have anything about the Fan PWM Offset. That's why Syscfg doesn't recognize that variable when trying to set. Read back my previous messages and see that I've been using the proper syntax.

So my question still stands: is there an ETA on a BIOS/firwmare/Syscfg fix?

idata
Community Manager
232 Views

Hello Szabolcs F,

 

 

We appreciate the additional information, we are going to provide the .ini log to our upper-level support so the can further assist you.

 

 

As soon as we get an update we will contact you back.

 

 

Best regards,

 

Sergio S.
idata
Community Manager
232 Views

Hello Szabolcs F,

 

 

First, we would like to apologize for the delay in our response.

 

 

For Fan PWM Offset changing please use dedicated command >syscfg -fan

 

 

See more details on page 44 of Syscfg User Guide https://www.intel.com/content/dam/support/us/en/documents/server-products/server-boards/Intel_Syscfg...

 

 

Saving and/or restoring PWM offset settings to or from the .ini file is a limitation that is going to be fixed on a future version of the SYSCFG Utility.

 

 

Please do not hesitate to contact us again if you need further assistance.

 

 

Best regards,

 

 

Sergio S.
idata
Community Manager
232 Views

Hello Szabolcs F,

 

 

I am following your question and we would like to know if you need further assistance.

 

 

Best regards,

 

 

Sergio S.
SF_
Beginner
232 Views

Hello,

thank you, it worked.

idata
Community Manager
232 Views

Hello Szabolcs F,

 

 

We are glad to hear that you were able to resolve your problem. Feel free to contact us back in case you need more assistance.

 

 

Best regards,

 

Sergio S.