Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage; and Intel® Xeon® Processors
4398 Discussions

S3210SHLC BIOS Update Problem

Community Manager

I apologize if this becomes a second copy of my first post, but I made my first post about 15 hours ago and I still don't see it on the board.

I have an S3210SHLC that I have tried to update the BIOS on. I downloaded the latest One Time Boot build for Windows and the latest firmware build from the Intel website. I extracted the firmware to c:\firmware, CD to flashupdt directory and ran "flashupdt -u c:\firmware\flashupdt.cfg". I was asked questions about the chassis and fans and the update completed without any errors, and without anything to indicate it was successful. I ran "flashupdt -i" and I was told "The BMC is in FW Transfer Mode". I have done several cold boots and I get the same error, and the BMC doesn't seem to be accessible. I moved the jumpers for "BMC FRC" to attempt to force an update. I ran the same steps as above to update the firmware and I got the same error. I have tried booting to the server deployment CD and I get that error when I agree to the license agreement. I put the "BMC FRC" jumper back to the default position and now in Windows when I run "flashupdt -i" I get the error "Failed to communicate with BMC".

Thankfully the server is still booting into Windows. The reason I'm doing the update is that the server for some strange reason keeps randomly powering itself off. There is nothing in the event logs that indicate a problem, and when the server comes back up I get Event ID 6008 (Unexpected Shutdown) logged. The server is not logging any STOP errors and there are no memory dumps. The server is plugged into a 1500VA UPS and all of the other peripherals don't have any downtime when this occurs. It happens at different times of the day and there aren't any noticeable power related issues (sags, surges, etc). I have replaced the power supply and I even tried moving the power cord into a different outlet on the UPS. The only thing I can think of is that the mainboard is detecting a thermal event, and for some reason it isn't showing up in the SEL logs. The ambient temp of the room does get up above 75 degrees F at times, and the CPU temp seems to be at acceptable levels even then, but I'm not sure what else to do at this point.

Thank you for your help.

0 Kudos
4 Replies

Did you try to update under EFI shell?

Community Manager

Yes, and my USB flash drive appears as BLK1:, but when I try to do a directory listing I get an error. The flash drive is formatted NTFS. Should it be formated as FAT?

Community Manager

Ok, I formatted a flash drive with FAT and extracted the firmware update onto it. I booted into the EFI Shell and the update script ran. When it was done I rebooted the server and the BMC still wasn't working and the BMC version info didn't show up in the BIOS under System Information. So I pulled all of the add-on cards out, moved the FRC BMC jumper to pins 2&3 and booted back into the EFI Shell. This time I tried only running the BMC update from the EFIScripts directory. I ran "fwiaupd -u -o -ni -pia -p -noverify -nopc 3210SH35.hex" and I got an error:

Error 005: Update failure.

Could not lock the front panel in EFI due to error communicating with BMC

When I run "fwiaupd -i" I get another error:

Error 037: Get mode error.

I have tried several other combinations of "fwiaupd -i" and I always get the "Could not lock the front panel in EFI due to error communicating with BMC" message. I'm desperate to get this working b/c if the server shuts itself off again I can't use the BMC to power it on remotely.



Can you try the BMC Force Update Procedure by moving jumper J1A2 to pins 2-3? Below is the step-by-step procedure:

1. Power down and remove the AC power cord.

2. Open the server chassis. For instructions, see your server chassis documentation.

3. Move jumper from the default operating position (covering pins 1 and 2) to the enabled position (covering pins 2 and 3).

4. Close the server chassis.

5. Reconnect the AC cord and power up the server.

6. Perform the Integrated BMC firmware update procedure as documented in the README.TXT file that is included in the given Integrated BMC firmware update package. After successful completion of the firmware update process, the firmware update utility may generate an error stating that the Integrated BMC is still in update mode.

7. Power down and remove the AC power cord.

8. Open the server chassis.

9. Move jumper from the enabled position (covering pins 2 and 3) to the disabled position

(covering pins 1 and 2).

10. Close the server chassis.

11. Reconnect the AC cord and power up the server.

Also, can you check the PBA# of your board? It's printed on the label on the board in ABCDEF-123 format.