Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage; and Intel® Xeon® Processors
4467 Discussions

SASWT4I RAID card and HP Z210 Workstation

Community Manager

Trying to get an Intel SASWT4I RAID card to work in an HP Z210 Workstation as a bootable RAID card. CPU is a Core i3 with 8GBs of ECC memory and two identical hard drives attached to the RAID card in connectors 0 and 1 and a DVD burner attached to the motherboard's SATA connector. One of the hard drives attached to the RAID card has Windows XP loaded on it for testing.

At boot, RAID card says to press Ctrl-C to enter RAID card setup menu. If I do this, it says it will load a configuration, then flashes something about loading the configuration (it's too fast to see what it says) and then the PC tries to load normally but fails saying it can't find any boot volumes. If I don't press Ctrl-C, the RAID card finds my two hard drives attached to it, then boots Windows XP off of the drive that has XP loaded on it. Once in Windows XP, when I run the Intel RAID configuration program, I can see both drives and the RAID card just fine.

To make sure the Intel RAID card is OK, I've installed it in a number of systems and pressing Ctrl-C during boot-time RAID initialization brings me directly to the setup menu as it's supposed to. This tells me it's an incompatibility between the HP's BIOS and the Intel RAID card. I've gone into the HP's BIOS and disabled the on-board RAID, AHCI, the DVD burner, drive compatibilty mode and made sure the BIOS was set to allow alternate controller BIOS downloads at boot. I also tried updating the Intel RAID card's BIOS and firmware through Intel's Windows configuration utility (NVData 2D.02, BIOS, and Firmware Also tried disabling the PC BIOS' Quiet boot mode, installing the RAID card in all the PCI-Express slots on the motherboard, attaching the hard drives in various ports on the card as well as not attaching any drives at all. Still doesn't work. The HP workstation has also been updated to the latest BIOS as well.

Any ideas? Anything I might have missed? Anything I might try? If there is an incompatilbity (which is what this appears to be) is there any mechanism to report this to Intel?



0 Kudos
2 Replies

It looks like HP only tested it on the Z600 and Z800 series.

Can you also try disabling network boot? Sometimes the PXE ROM sits in the same space as the RAID ROM.

Community Manager

Hi Dan_O,

Tried disabling the HP's PXE boot ROM but no dice. Two more things that bother me. First, the SASWT4I RAID card shows up fine once in Windows and two, the HP's on-board Intel chipset RAID works fine. This tells me the on-board Intel chipset RAID is probably what's interfering with the system loading the SASWT4I's option boot ROM. Unfortunately, the on-board RAID doesn't offer the features I need but the SASWT4I does. I contacted HP's support to report the incompatibility, but who know where that will go?

BTW, someone else reported having this same issue with the SASWT4I and an Intel chipset based motherboard:

I imagine HP would have to offer a BIOS update to fix this issue.

P.S. HP doesn't list any RAID cards compatible with the Z210 Workstation. You're basically on your own, which is ridiculous considering it's a workstation class machine.