Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4811 Discussions

Strange Problem with Intel Entry Storage System SS4000-E



I've been using the Intel Entry Storage System SS4000-E as a simple backup network drive for the last few years. It showed up as Drive Z: on all of my Windows machines and I just copied other drives/folders onto it as needed. It's far from the full capability of this device but it's suited my purposes.

Recently, I decided to upgrade the drives and increase the total storage space from 2 TB (4 500 GB drives, Raid 0) to 6 TB (4 1.5 TB drives). The software doesn't allow me to make one 6 TB drive, so I made three (X:, Y:, and Z:), with sizes ranging from 1.49 TB to 1.99 TB, accessible as \storage\public3, \storage\public2, and \storage\public1 respectively. I also created the required shared folders using the minimum (200 MB) for both so I could have as much room as possible for large shared partitions. I also took the opportunity to upgrade the firmware to version 1.4, build 709, since I was installing new drives.

I backed up some data to the Z: drive (\storage\public1) and filled about 1.5 TB. Then I started copying folders from another system to Y: drive (around 900 GB in all). Everything seemed to be going well until I looked in on the copy after around 800 GB had transferred. Files were being copied *extremely* slowly, like 100 MB in 10 minutes! I aborted the transfer and ran a test to eliminate network issues as the problem. I tried copying a 100 MB file from Y: drive to Y: drive. It took around 10 minutes, as above. I tried the same thing on Z: drive and it was almost instant. Something was somehow causing that part of the network drive to move at a snail's pace.

I then accessed the management screen via a browser and got a message saying that one or more drives had either failed or been changed (Disk Change Notification - raid_disks_changedF.cgi). Two tables that show all four disks - serial numbers and capacities - are shown, one table being previous configuration and the second being current configuration. Both tables are completely identical. Clicking on "Scan" or "Continue" resulted in the same message, so I clicked on "shut down" and tried to access the network drive after it rebooted. I had no problem getting into the Z: drive part of it but both X: and Y: weren't being seen at all anymore.

I'm aware of the fragility of a Raid 0 and wonder if it could be so easily disrupted during a large transfer such that I face the possibility of initializing all four drives and starting over. I'm at a loss as to what could be going wrong here or how to fix it. I really just want a simple means of copying lots of data over from various networked machines without any additional software. This system worked fine before. What could have happened?

Thanks for any help.


0 Kudos
1 Reply


The 1.5TB HDDs should work as the 1.4 version of firmware (operating system) supports storage capacity greater than 2 TeraBytes (TB). The storage is divided into 2TB partitions, including one for a shared public folder, one for user home folders and one for backups. However, Intel has never tested 1.5 TB HDDs and don't know how they'll work.\

That said, the way you've configured should be fine. The public1, public2 and public3 shared folders will actually be separate partitions like /dev/vbdi4. vbdi5 and vbdi6 mounted on /nas/NASDisk-00004, NASDisk-00005 and NASDisk-00006. These partitions and each be 2TB.

I don't know why the transfer to your Y: drive degraded. The different partitions are still part of the single RAID array. Unless there was damage to the specific sectors in this partition. The damaged sectors would be on a specific disk and may explain the "one or more drives had either failed or been changed" message.

Although RAID 0 is nice for the performance boost, you're subject to the possibility of data loss with the failure of 1 of the 4 drives. Thereby increasing the possibility of issues 400%. RAID 5 may be a better choice, especially with larger drives (more space even with the 25% loss because of the RAID).

You can troubleshoot the system by creating and a diagnostic file (XRay) for the SS4000 and analyzing the results. See:



0 Kudos