Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,422 Views

Unable to access http on RMM4 after disabling https

I have a R1208WFTYS system. When I try to open RMM web interface via http:// protocol, it redirects to https://. So I disabled "https" in security settings in web interface. After that I cannot connect neither https nor http.

I can access BMC via ipmitool - this is the only thing that works.

Is there any way to re-enable https (as it seems to be the root cause of my troubles) or reset RMM setting to defaults remotely? Maybe there is some magic ipmitool raw ... command to do that?

0 Kudos
18 Replies
Highlighted
Beginner
32 Views

I forgot to mention that this server has no OS installed, so remote access via ipmitool is the only way to communicate to the server (at least for now).

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov ,

 

 

Can you provide us the model of the board that you have?

 

 

 

Best Regards,

 

 

Charlie_Intel
0 Kudos
Highlighted
Beginner
32 Views

As I said I have no access to the system other than via ipmitool. Do R1208WFTYS have options on motherboard in them? I thought that there is only one motherboard option.

0 Kudos
Highlighted
Beginner
32 Views

TPS for R1000WF suggests that it is S2600WFT.

0 Kudos
Highlighted
Beginner
32 Views

BIOS screen says it is S2600WF, BIOS version SE5C620.86B.00.01.0013.030920180427

ipmitool mc info says BMC firmware revision 1.43

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov ,

 

 

Is there any way that you can physically access the server board BIOS?

 

 

 

Best Regards,

 

 

Charlie_Intel
0 Kudos
Highlighted
Beginner
32 Views

I have IP-KVM connected to server. So I can access BIOS settings screens. But I have no physical access to the server.

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

We can try resetting the BMC in the BIOS but this can restart the IP configuration in the BMC LAN options so, let me try here first if we can restart the defaults and then set the IP settings before the restart so you will not lose the connection.

 

 

I will let you know as soon as I test it.

 

 

 

Best Regards,

 

 

Charlie_Intel
0 Kudos
Highlighted
Beginner
32 Views

It is a hardware appliance IP - KVM, so I can do whatever you want with BIOS settings.

0 Kudos
Highlighted
Beginner
32 Views

I had arranged a bootable disk with OS plugged into my server so I successully reset RMM settings with syscfg utility. So the urgency is gone.

Anyway, I would appreciate if you would provide instructions on how to reset RMM settings:

1) remotely via ipmitool

2) via BIOS settings screen

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

We are glad to hear that the urgency is gone.

 

 

We were trying to find out a way to reset it remotely as you told us that you were not able to do it on site, but, I am not sure if it is possible without using syscfg.

 

Please let me do the consult and I will contact you back.

 

 

Best regards,

 

 

Charlie_Intel
0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

I already consult it and unfortunately, syscfg is the only way available to reset that configuration.

 

 

 

Best regards,

 

 

Charlie_Intel
0 Kudos
Beginner
32 Views

Ok, thank you anyway.

Is it normal that http access is also disabled when I disable https? Isn't it a bug?

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

That normally happens when you disable the option but we can take the feedback as well.

 

 

Please let us know if you have further questions.

 

 

Best Regards,

 

 

Charlie_Intel
0 Kudos
Highlighted
Beginner
32 Views

Please, forgive my persistence. You say that "http" access is disabled when I disable "https" in security settings? There are two separate checkboxes for "http" and "https", so that kind of behavior is at least strange and counter-intuitive.

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

Yes, we did the lab and we saw that behavior, we understand your concern, and we will take your feedback in order to watch it deeply.

 

 

Best regards,

 

 

Charlie_Intel

 

0 Kudos
Highlighted
Beginner
32 Views

Thank you, for your investigation. I have no more questions although I don't feel like "my problem is solved"... how do I close this discussion?

0 Kudos
Highlighted
Community Manager
32 Views

Hello SergeiTurchanov,

 

 

We will close it for you do not worry.

 

 

 

Best regards,

 

 

Charlie_Intel
0 Kudos