Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
4722 Discussions

VDs on S1200BTL & Windows 7



My end goal is this: Set up RAID 10 on 4 HDDs with Windows 7 Pro.

This is similar to /message/158584 this post, but I'm having trouble implementing the answer. Here is the situation:

System: P4303BTLSHCN

Board: S1200BTL

OS: Windows 7 Professional, 64-bit

Drives: Four (4) 2TB hard drives (& one DVD-ROM)

Bottom line: How do I finish with Win 7, RAID 10, and 4 TB storage, accessible through Windows?

Sticking points: Windows partition capabilities, RAID restrictions, virtual drive creation/modification . . .

More background:

/message/158584 The aforementioned post says to make a smaller virtual drive and install Windows on that. I'm using two utilities in trying to create such a partition, and a third trying to set up RAID:

  1. Intel Embedded RAID II Configuration Utility (Ctrl+E)
  2. GParted Live
  3. Intel Server Board S1200BT Family Server Deployment Toolkit 4.0 (bootable CD G20500-002)

Toolkit CD only offers low-level RAID, so I've mostly been ignoring that. If I create the partitions in GParted, I don't see any recognition of them in the Configuration Utility. If I create a virtual drive (tried 25 and 50 GB) in the Configuration Utility, it only allows RAID 0 for the small one, and then restricts the RAID level for the larger drives. In addition to just making one small partition and having the rest go more or less automatically, I've tried making 8 partitions/VDs (one small & one large on each drive) so as to keep all the same size for RAID, but that doesn't seem to matter. If I go straight to configuring RAID 10 without any prior divisions, it doesn't allow me to alter the size of the resulting drive.

Earlier in this process I set up RAID 10, installed Windows, and found only 2 TB available (on the C drive, with no other drives visible). During startup it listed the drives and recognized RAID 10 implemented. I checked BIOS and Config Utility settings. The other post appeared to be essentially the same situation, which is why I'm trying to make a boot partition. I've also tried advanced options on the Windows install, but apparently it can't handle more than 2 TB. When I did have Windows installed (with all updates), I tried everything I could manage on the Toolkit CD, Intel System Management Software (G10627-002) CD, and driver program available from

Fortunately all of the drives are new so I can format them all I want. For various reasons I'm trying to keep to Windows as the final OS, but I'm happy to use Linux in the process--but I can't claim to be an expert at it. My tech knowledge is well above average, but everything I know is only what I've (taught myself to be able to get) done. If you tell me to do some standard operation, if I don't know it I can ask Google. I just need a direction to look.

Thanks very much.

0 Kudos
4 Replies

I would probably consider going directly to the RAID BIOS (CTRL+E) to configure your array. Remember the 2TB limitation is for the bootable volume. This means that you should be able to create a smaller virtual drive; and then, create a second virtual drive for the remaining space.

I would need to test the configuration to see if it is possible to configure your RAID 10 using the entire possible drive capacity (approx 4TB) as a single Virtual drive and perform a GPT installation.

Feel free to contact our Intel Customer Support team for further follow up on this process.


Thank you for responding, David.

How would you test the configuration? Which components, which tools . . . ?

After the post I continued fiddling, creating partitions in GParted because I knew about the 2TB limit, and through Ctrl+E was able to set up RAID 10, then was finally given the option of installing Windows on a 25GB partition. So RAID is allegedly configured at 10, and the machine will boot to Windows 7. That's an improvement.

Windows displays the 25GB partition, an unspecified local drive, and the disc drive. According to Windows, the local drive must be formatted, which I would do, but some fiddling finally revealed it to be 1.79 TB.

Further exploration (Properties-->Hardware-->[disk device]-->Properties-->Change Settings-->Volumes-->Populate) declares the following:

Disk: Disk 0

Type: Basic

Status: Online

Partition style: Master Boot Record (MBR)

Capacity: 3,812,787 MB

Unallocated space: 189,424 MB

Reserved space: 0 MB

. . . and below, a list of the two local drives, stating the capacity of this one to be 1,882,128 MB.

The line in bold is what the capacity should be. Any ideas how I can access it?

Thanks very much!

0 Kudos

The idea is to use the RST controller instead of the ESRT2. This controller should allow you to create your RAID 10 and use the maximum volume size.

Once the volume has been created we need to do the following:

  • Go to BIOS > Boot Options > and enable EFI Optimized Boot, and Use Legacy Video. Press F10 to Save and Exit.
  • Launch the installer under EFI. (\EFI\BOOT\BOOTX64.EFI) and continue with your Operating System installation.
  • For more information, please refer to the following White Paper.

Feel free to contact our Intel Customer Support team for assistance on this process.

0 Kudos

David, you're very helpful! I've spent some quality time with the white paper, although unfortunately it has some key differences from my system. (For anyone else who has this problem, the white paper doesn't specify the need to change to from ESRT2 to RSTe in BIOS --> Advanced Menu --> Mass Storage Configuration, and you may need to use Ctrl+I instead of Ctrl+G. The white paper says to install the RAID controller driver, so I searched for the appropriate one, which I hope was right.)

Then I installed Windows--on a >2 TB partition--and it's registering all the free space! I haven't yet been able to verify that the array is working properly, but it sees the drives and shows the amount of space it should have!

Thank you!

0 Kudos