Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
266 Views

"syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

A Services guy did disable the HTTPS access by error from the RMM4 GUI and we can't recover the previous state and we don't have anymore access to the RMM4 Web features. The customer lab is available only remotely so we are blocked to change any parameters from the BIOS menu

 

Via SSH, I tried this Sysconfig command but the tool reports bad arguments while I follow the command line requested into the RMM4 Intel User guide.

"syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

 

Some information about this module:

 

"syscfg /d lan 3"

LAN Configuration Settings:

---------------------------

LAN Channel Selected: 3

LAN Alert Destination Index Selected: None. LAN Alert Configuration will not be displayed.

IP Address Source: DHCP

DNS Primary Server IP Address: 10.86.88.200

DNS Secondary Server IP Address: 10.86.88.100

DHCP Host Name: BMCA4BF013E6701

LAN Failover Mode: DISABLE(NIC1:DISABLE,NIC2:DISABLE,NIC3:DISABLE,PrimaryNIC:1)

BMC Host IP Address: 10.86.74.144

Subnet Mask: 255.255.248.0

Gateway IP Address: 10.86.72.1

Gateway MAC Address: 00-00-00-00-00-00

Backup Gateway IP Address: 0.0.0.0

Backup Gateway MAC Address: 00-00-00-00-00-00

Community String: public

Gratuitous ARP Enable: DISABLE

Gratuitous ARP Interval (milliseconds): 4

BMC ARP Response Enable: ENABLE

 

"syscfg /d user 2 3"

----------------------------

User ID Selected: 2

Channel Selected: 3

User Name: root

User Status: ENABLE

Privilege Level Limit: ADMIN

SOL Enable: DISABLE

 

 

Any help would be appreciated.

0 Kudos

Accepted Solutions
Highlighted
Novice

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello Jose,

 

Here is the response from our customer:

 

Thanks for this update. I did try first to use the command remotely with the “-I lanplus” parameter but it failed all the time with this error:

Error in open session response message : insufficient resources for session

 

Error: Unable to establish IPMI v2 / RMCP+ session

 

None of the hundred google tips to try to fix this error did work. If Intel has any clues on this I would be happy to know it….

 

However using an SSH session on one of the other IP port of an affected system works. So the workaround so far is the following:

  • Log to the server with SSH on the IP server network address
  • Once logged, enter the following command: “ipmitool raw 0x30 0xb1 0x01 0x79 0x00”
  • Reboot the system
  • You will be able to log again on the RMM Web GUI page

 

Please report to Intel in case they have a way to fix remote IPMI issues as stated above.

 

Thanks,

View solution in original post

0 Kudos
9 Replies
Highlighted
Moderator

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello PLe3,

 

Thank you for joining the community

 

For our records could you please tell what board model do you have?

About the syscfg arguments we will need to do further research. In the meantime you can check the SYSCFG user guide

 

We will look forward for your updates

 

Jose A.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Highlighted
Novice

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello Jose_Intel,

 

Thank you for your reply. I checked the user guide. The command syscfg /hc https 3 enable 443 is correct.

 

I am gathering more info on the motherboard model. Will update shortly.

 

Thank you

0 Kudos
Highlighted
Novice

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Here is the motherboard info:

 

It’s an S2600WFT with BIOS 2.01.008 installed.

Manufacturing Time(mins)         : Tue Aug 29 11:05:00 2017

Manufacturing Name(ASCII)      : Intel Corporation

Product Name(ASCII)                   : S2600WFT

Serial Number(ASCII)                    : BQWF73400369

Part Number(ASCII)                       : H48104-850

Mftr FRU File ID(ASCII)                : FRU Ver 1.00

 

Sysinfo of the system is also attached

0 Kudos
Highlighted
Moderator

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello PLe3,

 

Thanks for the updates. I will research about the syscfg commands and will let you know as soon as possible.

 

Regards

 

Jose A.

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos
Highlighted
Moderator

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello PLe3,

 

Could you please try to run the following raw IPMI command: "raw 0x30 0xb1 0x01 0x79 0x00"

 

The example command would be similar to "ipmitool -I lanplus -H <IP address> -U <user> -P <password> raw 0x30 0xb1 0x01 0x79 0x00" to enable the HTTPS services for BMC web console. Here the <IP address>, <user> and <password> are for the BMC of remote system. Refer to the specific open ipmitool for the exact command format.

 

Regards

 

Jose A.

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos
Highlighted
Novice

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello Jose,

 

Thank you. I will let you know if it works or not.

0 Kudos
Highlighted
Moderator

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello PLe3,

 

We will wait for your updates.

 

Regards

 

Jose A.

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos
Highlighted
Novice
1 View

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello Jose,

 

Here is the response from our customer:

 

Thanks for this update. I did try first to use the command remotely with the “-I lanplus” parameter but it failed all the time with this error:

Error in open session response message : insufficient resources for session

 

Error: Unable to establish IPMI v2 / RMCP+ session

 

None of the hundred google tips to try to fix this error did work. If Intel has any clues on this I would be happy to know it….

 

However using an SSH session on one of the other IP port of an affected system works. So the workaround so far is the following:

  • Log to the server with SSH on the IP server network address
  • Once logged, enter the following command: “ipmitool raw 0x30 0xb1 0x01 0x79 0x00”
  • Reboot the system
  • You will be able to log again on the RMM Web GUI page

 

Please report to Intel in case they have a way to fix remote IPMI issues as stated above.

 

Thanks,

View solution in original post

0 Kudos
Highlighted
Moderator

Re: "syscfg /hc https 3 enable 443" -> Invalid data in the switch parameters

Jump to solution

Hello PLe3,

 

Thanks for the feedback. We will definitely report it to engineering in order for this issue to be noted. For now we will proceed to mark this thread as resolved. If you have further issues or questions just go ahead and create a new topic.

 

Jose A.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos