Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,879 Views

this time: S5520HC with 2*Xeon X5680 - unable to finish Windows 7 64-bit installation

No install process for any Windows 7 can finish in resonable time.

Otherwise, evrything seems OK.

This board - Intel® Server Board S5520HC:

Intel® 5520 ChipsetIntel® 82801JIR I/O Controller Hub (ICH10R) Intel® 82801JIR I/O Controller Hub (ICH10R)Can someone help me?
0 Kudos
8 Replies
Highlighted
Valued Contributor III
51 Views

Connect both NIC together with a network cable and the install will complete.

Then update the NIC driver. (embedded NIC driver has issues)

or

update the BIOS and disable AER, then let the install complete, update the NIC drivers then you can ture AER back on if desired.

http://www.intel.com/support/motherboards/server/sb/CS-031086.htm?wapkw=(high+cpu+NIC http://www.intel.com/support/motherboards/server/sb/CS-031086.htm?wapkw=(high+cpu+NIC)

Highlighted
Beginner
51 Views

Thanks,

connecting the two NIC works. But the information reffered to says:

"This issue only affects network controllers based on the 82575 or 82576 chipset."

Obviously, this issue affects more chipsets or it is independent on the hardware?

0 Kudos
Highlighted
Valued Contributor III
51 Views

Good to hear you got it running.

HC uses the 82575eb Network controller. (Not be be confised with the S5500 chipset )

The real clue is

This applies to: (Every server board Intel makes) http://support.intel.com/support/motherboards/server/s3420gp/ Intel® Server Board S3420GP

 

http://support.intel.com/support/motherboards/server/s5500BC/ Intel® Server Board S5500BC

 

http://support.intel.com/support/motherboards/server/s5500hcv/ Intel® Server Board S5500HCV

 

http://support.intel.com/support/motherboards/server/s5500wb/ Intel® Server Board S5500WB

 

http://support.intel.com/support/motherboards/server/s5520hc/ Intel® Server Board S5520HC

 

http://support.intel.com/support/motherboards/server/s5520ur/ Intel® Server Board S5520UR

 

http://support.intel.com/support/motherboards/server/sc5650bcdp/ Intel® Server System SC5650BCDP

 

http://support.intel.com/support/motherboards/server/sc5650hcbrp/ Intel® Server System SC5650HCBRP

 

http://support.intel.com/support/motherboards/server/sr1600ur/ Intel® Server System SR1600UR http://support.intel.com/support/motherboards/server/sr1625ur/ Intel® Server System SR1625UR

 

http://support.intel.com/support/motherboards/server/sr1630bc/ Intel® Server System SR1630BC

 

http://support.intel.com/support/motherboards/server/sr1630gp/ Intel® Server System SR1630GP

 

http://support.intel.com/support/motherboards/server/sr1630hgp/ Intel® Server System SR1630HGP

 

http://support.intel.com/support/motherboards/server/sr1690wb/ Intel® Server System SR1690WB

 

http://support.intel.com/support/motherboards/server/sr2600ur/ Intel® Server System SR2600UR

 

http://support.intel.com/support/motherboards/server/sr2625ur/ Intel® Server System SR2625UR

 

http://support.intel.com/support/motherboards/server/s5520sc/ Intel® Workstation Board S5520SC

 

http://support.intel.com/support/motherboards/server/sc5650scws/ Intel® Workstation System SC5650SCWS

http://download.intel.com/support/motherboards/server/s5520hc/sb/e39529013_s5520hc_s5500hcv_s5520hct... http://download.intel.com/support/motherboards/server/s5520hc/sb/e39529013_s5520hc_s5500hcv_s5520hct... Page 17

I/O control support

 

External connections:

 

DB9 serial port A connection

 

One DH 10 serial port connector (optional)

 

Two RJ-45 NIC connectors for 10/100/1000 Mb connections: Dual GbE through the Intel® 82575EB Network Connection.

 

Four USB 2.0 ports at the back of the board

 

Internal connections:

 

Two 9-pin USB headers, each supports two USB 2.0 ports

 

One DH10 serial port B header

 

Six SATA connectors at 1.5 Gbps and 3 Gbps

 

Four SAS connectors at 3 Gbps (optional)

 

One SSI-compliant 24-pin front control panel header
0 Kudos
Highlighted
Beginner
51 Views

Thank you again.

But ... I haven't finished yet.

This time I can't get the onboard SATA controller working in AHCI mode which I think is possible or it is meant to be possible.

The Win7 installation went in controller's ENHANCED mode.

Neither could Win Installer's drivers nor loaded Intel's S5500 AHCI SATA Driver for Win 7 do the Win 7 installation with onboard SATA controller working in AHCI mode.

The Win7 installer could only execute the boot table operations: Delete, New, Format (at least it pretended doing them).

After running the Intel(R) Chipset Device Software the Device manager shows two Intel ® ICH10 Family 2 port Serial ATA Storage Controllers (plus 2 x ATA Channel 0 and 2 x ATA Channel 1 – there are 6 SATA connected ports on the board so, I don't understand this also).

The only executable file found in the RST_9.6.4.1002_Win_drivers_and_utils pack, this is the S5500 Based Server AHCI SATA Storage Driver for Windows, iata_cd.exe when started finishes with an error message: "The computer does not meet the minimum requirements for installing the software".

Can someone explain me that?

And can I set the AHCI mode for the onboard SATA controller or not?

(BIOS is in version 0048).

Tested operating system reports http://www.intel.com/support/motherboards/server/sb/CS-029644.htm http://www.intel.com/support/motherboards/server/sb/CS-029644.htmIntel® Server Board S5520HCS5520HC - Configured in SATA AHCI mode and Intel® Xeon® Processors& 5500 series:There is a report only for Microsoft Windows Server 2008* R2 x64 and Windows Server 2008* SP2 x32 x64& bit version.

Message was edited by: SpasV

0 Kudos
Highlighted
Valued Contributor III
51 Views

First off, I would update the code stack to the current level. BIOS 48 was OK, but current is BIOS 60 -- 12 BIOS release is a lot of bug fixes and changes. (You would not have see the NIC issue on BIOS 60 as it works around the AEC issue)

You download the right drivers (RST_9.6.4.1002_Win_drivers_and_utils.zip)

Extract the drivers to a USB key fob you should get a drivers folder and a utils folder.

Boot into BIOS set up (F2) and enable the AHCI mode.

Save (F10) and reboot to the instlation DVD.

You should get to this screen after a bit.

If you have any exsisting partions, I would delete them and start clean.

Then select the load driver

Select the Browser button and point to your USB location with the AHCI drivers.

(You can also load the newest NIC drivers here and avoid the NIC issue with the older BIOS.)

System will load the AHCI driver (It may warn about the driver being sign) and then allow you to select the HDD and off you go.

0 Kudos
Highlighted
Beginner
51 Views

Thank you for helping me.

I had to update the BIOS (the current vresion is 59) and to face another problem this time.

It took me time to understand the reason but it turned out that USB port mounted on the board has probably some special hiden function.

So, I left the flash drive there after upgrading the BIOS and couldnt do anything meaningful.

The Win 7 installer while working in AHCI/ENHANCED mode keep generating errors saying something like "Windows cannot be install on this disk" not showing which one and I assumed it was the disk I wonted to innstall Windows to or "Setup was unable to create/locate a system partition". The actual disk was readable, writable (maybe during the time the USB flash drive was not connected) all that time.

Finally, I run XP installer and it shown me the only HDD availale for the installation was the FAT32 formated USB flash drive.

After that I was able to install Windows 7 with onboard SATA controller in AHCI mode. Finally.

But this wasn't the final error I faced.

The final was in PROSETDX.msi - the The network driver installer. It needs .net 3.0 or later but working in .net 4.0 enwironment it failed.

The workaround is to start DxSetup.exe which did the job.

0 Kudos
Highlighted
Community Manager
51 Views

I'm not aware of any hidden functions of the onboard USB port. Windows not only saw your flash drive, but saw it first. And it thought that it was kind of small to be your install target. Best to start the install without that present, because if you manage to work around it, you can end up with D: as your system device. That works, more or less, but can end up confusing other software, and especially yourself.

0 Kudos
Highlighted
Beginner
51 Views

In order for EFI to work the USB drive needs to be FAT formatted.

No Windows (NT starting at 4) OS installs on FAT formated drive. (Window 7 is Windows 6.1).

It was Windows XP installer (without AHCI mode drivers) to show me the USB device as an instalation target device. And that was the only device while there was a SATA drive present also. (Maybe, this was in AHCI mode of the on board SATA controller. I don't remeber.)

Windows 7 installer could read all drives presented in the system, when "browsing" to find a driver to be loaded, and it didn't say explicitly anything about the instalation target device. Because of the error mesages I could think its installation target was this USB FAT formatted device.

0 Kudos