Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Russell_B_1
Beginner
70 Views

Bricked Curie

It looks like I managed to Brick my Arduino 101 using Intel Studio for Microcontroller. It look to me that the processor was running @ 22.5MHz instead of 32MHz. I thought that the Crystal osc may not be enabled. I tried to enabled it through register 0xb0b00008. This resulted in me bricking the module. I can no longer update my app or even the Microcontroller ROM. I have attached a jpg of the error I get when trying to update the microcontroller ROM through projects. Does anyone know how I can recover. I and using a JTAG flyswatter2 interface for flashing.

0 Kudos
2 Replies
Russell_B_1
Beginner
70 Views

After bricking my Ardudio 101 I got a new one. When I load my program under Ardunio and run my SPI port @ 8MHz I get a clock period of .125us as expected.

When I update my ROM under Intel Microcontroller Studio and load my program my SPI port clock runs at .170us. It not just the SPI clock that is affected everything is slowed down by a factor of .703 as if the clock is running @ 22.5MHz instead of 32MHz.

I looked at location 0xB0800008 and it had a value of 0x00040002 this indicates it is running from the Silicon Oscillator not the Crystal Oscillator. Also the Crystal Oscillator has a trim of 15.03pf where the recomened is 10pf. When I tried to change this to the Crystal I Bricked the 101.

The 101 has a crystal in the Curie module.

I am trying to develop a program with exact timing and need to use the crystal. 

How do I change to the crystal without Bricking another 101?

Harold_G_Intel
Employee
70 Views

Hi,

For support regarding  Intel® Curie, please post to the communities here: https://communities.intel.com/community/tech/intel-curie/

Or, you can submit a support ticket  here: http://www.intel.com/p/en_US/support/contactsupport

Regards, Hal

Intel(R) Developer Zone Support

http://software.intel.com
*Other names and brands may be claimed as the property of other

Reply