Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
21 Views

Error -9 on project upload

I've been getting this a lot lately...  Seems to go away every 3rd or 4th build attempt and then I get a good build.

ERROR (-9) from "client:upload-manager": Error in uploading project files: : Http request failed Error at new ComponentError (C:\Users\username\AppData\Local\Intel\XDK\xdk\core-modules\public\component-error.js:17:1122) at makeError (file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:170) at getComponentError (file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:265) at file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:11779 at _rejected (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:844:24) at C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:870:30 at Promise.when (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:1122:31) at Promise.promise.promiseDispatch (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:788:41) at C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:604:44 at runSingle (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:137:13)


ERROR (-9) from "client:upload-manager": Error in uploading project files: : Error in uploading project files: : Error in uploading project files: : read ECONNRESET Error at new ComponentError (C:\Users\username\AppData\Local\Intel\XDK\xdk\core-modules\public\component-error.js:17:1122) at makeError (file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:170) at getComponentError (file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:265) at file:///C:/Users/username/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:12998 at _rejected (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:844:24) at C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:870:30 at Promise.when (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:1122:31) at Promise.promise.promiseDispatch (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:788:41) at C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:604:44 at runSingle (C:\Users\username\AppData\Local\Intel\XDK\xdk\node_modules\q\q.js:137:13)

Tags (2)
0 Kudos
8 Replies
Highlighted
21 Views

0 Kudos
Highlighted
New Contributor I
21 Views

I read those... since I'm using 3522 and the problem JUST started surfacing within the last few days and since it's every THIRD build and since I don't use a proxy... I don't think those solutions what I need.

Oh... and I've had two consecutive successful builds today... maybe this problem has to do with your end... 

0 Kudos
Highlighted
21 Views

Phil -- I've asked someone from engineering to contact you directly so we can get more details on the failure. We've not gotten any clear data from those who have encountered this issue and I'm hoping you might be able to provide some details that would help us to resolve the issue. They'll contact you directly either by private message or via the email address you're using for your forum login and may ask you to perform some specific tests on your machine.

0 Kudos
Highlighted
New Contributor I
21 Views

Paul F. (Intel) wrote:

Phil -- I've asked someone from engineering to contact you directly so we can get more details on the failure. We've not gotten any clear data from those who have encountered this issue and I'm hoping you might be able to provide some details that would help us to resolve the issue. They'll contact you directly either by private message or via the email address you're using for your forum login and may ask you to perform some specific tests on your machine.

I'll do my best.... as I said, I haven't gotten the error this workweek...  Today however, I have been getting some errors about slow uploads to the server with a refresh icon.  What's weird is that the server apparently already has all the files and when you hit refresh, a few seconds later you get a completed build.

0 Kudos
Highlighted
21 Views

Phil -- I suspect the behavior you are seeing is related to the other problem, so the experiments Bryon asks you to do are probably still worthwhile.

0 Kudos
Highlighted
New Contributor I
21 Views

Yep... I did what he asked... amazingly the problem duplicated itself, I documented it and sent it to him.  Haven't had the problem since either. :-)

0 Kudos
Highlighted
21 Views

I think he has some ideas as to what is going on, he was mumbling about something earlier today, but I did not get the full gist of his mumbles. Thanks for the help. :-)

0 Kudos
Highlighted
New Contributor I
21 Views

We've all been there... let me know if I can do anything else to move the cause forward.

0 Kudos