Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AVish2
Beginner
33 Views

Fb plugin addition

I got this error in build log after adding a fb plugin

All input files are considered out-of-date for incremental task ':CordovaLib:transformNative_libsWithMergeJniLibsForDebug'.
:CordovaLib:transformNative_libsWithMergeJniLibsForDebug (Thread[main,5,main]) completed. Took 0.003 secs.
:CordovaLib:transformNative_libsWithSyncJniLibsForDebug (Thread[main,5,main]) started.
:CordovaLib:transformNative_libsWithSyncJniLibsForDebug
Executing task ':CordovaLib:transformNative_libsWithSyncJniLibsForDebug' (up-to-date check took 0.0 secs) due to:
  No history is available.

Merging activity#com.facebook.FacebookActivity with lower [com.facebook.android:facebook-android-sdk:4.14.1] AndroidManifest.xml:29:9-32:75
Merging result:ERROR
.../cordova_project/platforms/android/AndroidManifest.xml:16:5-74 Error:
	uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [com.facebook.android:facebook-android-sdk:4.14.1] .../cordova_project/platforms/android/build/intermediates/exploded-aar/com.facebook.android/facebook-android-sdk/4.14.1/AndroidManifest.xml
	Suggestion: use tools:overrideLibrary="com.facebook" to force usage

See http://g.co/androidstudio/manifest-merger for more information about the manifest merger.

:processArmv7ReleaseManifest FAILED
:processArmv7ReleaseManifest (Thread[main,5,main]) completed. Took 0.104 secs.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':processArmv7ReleaseManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [com.facebook.android:facebook-android-sdk:4.14.1] .../cordova_project/platforms/android/build/intermediates/exploded-aar/com.facebook.android/facebook-android-sdk/4.14.1/AndroidManifest.xml
  	Suggestion: use tools:overrideLibrary="com.facebook" to force usage

Please help me out.

Tags (2)
0 Kudos
1 Reply
PaulF_IntelCorp
Employee
33 Views

The answer is right there, in the error log you posted:

uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library

You need to set the "Minimum Android API" to 15. See image below:

Screen Shot 2017-03-06 at 08.54.21 .png

Reply