Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Leonidas_S_
New Contributor I
108 Views

My Apple provisioning profile expired .. in the mid the XDK for Cordova has been terminated

My Apple provisioning profile expired .. in the mid the XDK for Cordova has been terminated,... I went create with my Mac a new cer(must use first cert or create another???) and P12 and provisioning but used other password than the first cert... and when in Phonegap build get error the:

Error - the password for the associated certificate is incorrect - You can fix this here

What have to do... use procedure with same password(FROM 2016) Or in addition use initial cert ? or have to create other cert > P12>provisioning???

 

Tags (2)
0 Kudos
11 Replies
PaulF_IntelCorp
Employee
108 Views

When your iOS build certificate and/or mobile provisioning file expires you need to go to your Apple Developer account and generate a new set of certs. You do not need to continue to use the same set of certs, for iOS, you can simply get a new set from your account. See these doc pages for help:

Leonidas_S_
New Contributor I
108 Views

But password is correct, why getting:

Error - the password for the associated certificate is incorrect - You can fix this here

 

PaulF_IntelCorp
Employee
108 Views

The only reason I can imagine for getting that error is that you are providing the wrong password. Regardless, it's much simpler to generate a new set of certificates, trying to resolve this issue is not worth your time or effort, just create a new build cert and provisioning file.

Leonidas_S_
New Contributor I
108 Views

BTW the zip ( Create Project )  in the deprecated XDK for Cordova --- neeeds to add anything for iOS ... In config.xml  I do not see iOS version ....????

PaulF_IntelCorp
Employee
108 Views

I'm not sure I understand the issue. The platform boxes must be blue if you want to see output for that selected platform (see the image below). Also, the Build Settings section for iOS must be configured, on the Projects tab, if you want meaningful output in the config.xml file.

Screen Shot 2017-07-12 at 14.24.54 .png

 

Leonidas_S_
New Contributor I
108 Views

yes are ALL Blue, and appear iOS settings since app had build for iOS too and had settings ... but where is iOS app version eg 1.5 after revision 1.7... etc 

I searched config.xml but not found it... well?

PaulF_IntelCorp
Employee
108 Views

Open the ZIP file that was exported using the tool described here > https://software.intel.com/en-us/xdk/docs/build-xdk-app-with-phonegap-cordova-cli < and within it you will see a config.xml file that directs builds with PhoneGap Build or Cordova CLI. That file contains all the instructions needed to build your app.

I do not understand what you mean by "but where is iOS app version eg 1.5 after revision 1.7... etc"

Leonidas_S_
New Contributor I
108 Views

So, if have in Create Project all Blue Android , WP , iOS pressing create project do only one zip correct FOR ALL??? I get one zip but first line was in config.xml>>>   // well where is the iOS version? eg I think in xdk settings was version iOS 1.5 but searched config.xml without find 1.5...well?

<widget xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0" xmlns:cdv="http://cordova.apache.org/ns/1.0" xmlns:android="http://schemas.android.com/apk/res/android" android-versionCode="240" ios-CFBundleVersion="1.0" windows-packageVersion="1.0.5" version="2.1.0" id="org.polischrysochous.polisappxdk2" >
 
PaulF_IntelCorp
Employee
108 Views

Yes, one ZIP is created to be used for building ALL platforms that you have selected in BLUE.

There are two fields in the widget header that determine your iOS version:

  • ios-CFBundleVersion -- which is like the Android versionCode number
  • version -- which serves all three platforms so has a priority order

That second parameter "version" is a generic version number that doesn't really determine the version used in the store to determine what is the "latest" version of your app. This is handled differently by each store, you'll have to do some research to fully understand that.

Regarding the "version" field, the Cordova project considers this to be a single version number that is used for all platforms. Unfortunately, this is an overly simplified view of the world, so it doesn't always work. If you have different versions for each platform it does not work. To get around this, if you export the ZIP and select ONLY iOS, you'll see your iOS version number in this field. If you select Android you'll see the Android version number. Here's the basic priority of how the "version" field is determined:

  • if Android is selected (blue), the "version" field reflects your Android version number in the Build Settings section
  • if Android is NOT selected (gray) and iOS IS selected, then the iOS version number will be used
  • if only Windows is selected (Android and iOS are gray), then the Windows version number will be used

Hope this helps.

Leonidas_S_
New Contributor I
108 Views

I will look in the subject

PHonegap Build ask for cert for Win 10 [in xdk not used cert file] ... how create...provide url...?

PaulF_IntelCorp
Employee
108 Views

Reply