Software Archive
Read-only legacy content
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Phonegap Build Errors No XWalk

GERBOIN_Y_
Beginner
138 Views

Hello,

Excuse my english, I'm french and it's my first post here.

I recently discovered updates about build on xdk. I used before the cordova hybrid mobile app with no problem for Android and iOS.

My apps needs the Crosswalk runtime (i use it in a shared version to limit size of differents apps).

I test the new Cordova Build Package. I've exported it in the Adobe Phonegap Buil with certificates.

Build was ok on Android, iOS or Win10 but when I test, it doesn't need the XWalk Runtime.

It runs with another runtime and I meet some errors.

For example, I use responsivevoice.js for TTS. It runs correctly with XWalk but with Phonegap Build I have the 'no speech function' error.

How can I use XWalk with Phonegap Build ?

Do I need Embedded ?

Thanks

Yvan

0 Kudos
4 Replies
Alex_Hang
New Contributor II
138 Views

Hello sir

I found on the PhoneGap Website that you have to add this line to your config.xml

<plugin name="org.crosswalk.engine" spec="1.3.0" source="pgb" />

Here is the PhoneGap website article https://build.phonegap.com/plugins/3347

You can find more about this problem on this Stack Overflow topic  http://stackoverflow.com/questions/38518219/getting-crosswalk-to-work-with-phonegap-build

GERBOIN_Y_
Beginner
138 Views

I added third plugin in intel xdk : cordova-plugin-crosswalk-webview

It's good with embedded mode (include arm and x86) : ResponsiveVoice runs correctly

I found that on Crosswalk project on the sharde mode page

Note: shared mode is not yet supported by cordova-plugin-crosswalk-webview

Intel shared mode compatibility miss me. Apk size is larger.

Yvan

PaulF_IntelCorp
Employee
138 Views

You can only build Crosswalk in "shared" mode using the XDK build system or with Cordova CLI. This is because the Crosswalk plugin includes a gradle build file > https://github.com/crosswalk-project/cordova-plugin-crosswalk-webview/tree/master/platforms/android < that is allowed (as a special exception) in the XDK build system but is not allowed (actually, it is ignored) in the PhoneGap Build system.

In addition, the Crosswalk plugin includes some "hooks" scripts, which are also ignored by PhoneGap Build. The xwalk.gradle file is needed to enable the shared mode build, without it, the build will not take place. Fortunately, the embedded builds work, but only because the default settings used within them work without requiring the gradle file and hooks scripts.

If you restrict yourself to targeting Android 5.x and later you do not need to build with Crosswalk. To do that, change the Minimum Android API setting to 21. Then your app can only be installed on Android 5 or greater devices. You can leave the "target API" set to 21.

GERBOIN_Y_
Beginner
138 Views

Ok thanks Paul & Alex

That's what I supposed.

I will test later with Cordova Cli but I need to learn how to build in command lines.

I will close this thread later.

Yvan

Reply