Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jiri_V_
Beginner
107 Views

SR300 RGB sensor not working, IR/depth does

Hi all, got the new dev kit with SR300, I have gen6 CPU and meet all requirements.

SDK hangs on the acquire call every time color RGB capture is enabled, unfortunately that includes most of the stuff like face tracking. The RGB camera does not work on its own in any other SW, no frames ever arrive. Raw IR and depth streams work fine. SDK samples that use color data freeze on Start (and that is lot of them).

Tried other computers, reinstalling drivers and SDK, RGB camera in installed in the system, just does not work.The RGB camera uses stock MS driver from 2006, but I assume that is ok as it is only a generic color camera device.

I'm thinking about sending it back as this is very strange, but it can still be only a driver problem. Doesn't seem likely that only the RGB function would fail to work.

Thanks in advance for any tips,
Jiri

0 Kudos
1 Reply
Jiri_V_
Beginner
107 Views

Well, it is a serious problem with the Intel driver installer.

I installed an older, no longer downloadable, intel_rs_dcm_sr300_3.0.24.59748.exe, it asked for FW update (the current driver did not) and then it worked. Uninstalled the old DCM and installed the most recent intel_rs_dcm_sr300_3.1.25.2599.exe and NOW it also updated the camera FW and bam it works. God that was frustrating.

My hint was this https://github.com/IntelRealSense/librealsense/issues/151

Cheers,

Jiri

Reply