Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Larry_B_
Novice
96 Views

VTune 2016 Update2, SuSE SLES 12 "manual" install?

Jump to solution

We're not having any luck installing VTune 2016 Update2 on a SLES 12 system.

We haven't pin-pointed the exact failure, but suspect that some *.so referenced by the install.XXXX/activation/activation.so is not available. (eg in addition to libexpat).

Our intention is to use a (MAC-derived) named-license file (no internet access).

It looks, in passing, like we might be able to simply install the *.rpms extracted from the vtune_amplifier_xe_2016_update2.tar.gz (and/or unpack the rpm's and have a look at the *spec files for further installation clues).

Has anyone else managed to do a Vtune "manual" install, who could provide approximate/rough guidance on what to look out for?

for reference, we were able to install on Fedora 20, same system. (but not Fedora 23, so far).

0 Kudos
1 Solution
Larry_B_
Novice
96 Views
putting this up here, in case it might be of help to someone attempting an install,
and/or perhaps someone on the Intel dev staff might recognize the issue: 

TL;DR version: 
using a preloaded .so, worked around 2 unresolved functions, in [..]/activation/activation.so

Longer version: 

# nm -D /tmp/install.XXXXXX/activation/activation.so | grep -Pi '9f4df'
[..etc..]
00000000000f4980  T Ox09f4df2d445e589f
00000000000ec320  T Ox09f4df2f39092c7f
                  U Ox09f4df3a72e6a401
000000000014f3b0  T Ox09f4df44222da90e
000000000016f810  T Ox09f4df47247ee5bb
                  U Ox09f4df535973f202
00000000000ffa30  T Ox09f4df5e31fdf639
[..etc..]

#  Work-around:
#  made a sharable containing the following:

  // gcc -m64 -O0 -ggdb3 -Wall -fPIC -shared -o dummy_preload.so dummy_preload.c
  int Ox09f4df3a72e6a401( void ) { return 0; }
  int Ox09f4df535973f202( void ) { return 0; }

  // (no idea what these missing functions might be,
  //  perhaps obfuscated libc or flexlm calls/wrappers ..)

# modified the ./vtune_amplifier_xe_2016_update2, like so:

  --- ./.backups/install.sh;1     2015-12-21 15:48:17.000000000 -0800
  +++ ./install.sh                2016-03-03 20:49:11.089999842 -0800
  @@ -769,7 +769,7 @@

  if [ "yes" = "${skip_gui_install}" ] && [ $online_installer_flag -ne 1 ] ; then
       if [ ! -z "$pset_engine_cli_binary" ]; then
  -        "$pset_engine_cli_binary" --TEMP_FOLDER="$temp_folder" $params
  +        LD_PRELOAD=/root/dummy_preload.so "$pset_engine_cli_binary" --TEMP_FOLDER="$temp_folder" $params
           exit_code=$?
       else
           echo "Missing install binary file. Please check the package and try again."

 

View solution in original post

4 Replies
Larry_B_
Novice
96 Views
f.ex: 

/tmp/install.4Y4AKi/activation/activation.so: undefined symbol: Ox09f4df535973f202

1456162910 - : sequence_execute_document: call "activation_init_action" C plug-in
1456162910 - : env_set_string_internal: key "PWD" with value "/tmp/install.4Y4AKi/activation" (length 30)
1456162910 - : plugin_run: library is "/tmp/install.4Y4AKi/activation/activation.so", func is "activation_init"
1456162910 - ERROR: : plugin_run: /tmp/install.4Y4AKi/activation/activation.so: undefined symbol: Ox09f4df535973f202
1456162910 - : env_set_string_internal: key "EXIT_CODE" with value "-1" (length 2)
1456162910 - ERROR: : src/env.cpp:93: parameter is null
1456162910 - : cond_is_true: condition is ${ACTIVATION_INIT_DONE} = yes, result is 0
1456162910 - : sequence_execute_document: detecting transition. Handle: , condition: ${ACTIVATION_INIT_DONE} = yes, next_cur: 0, next_shift: 0, act: 0
1456162910 - ERROR: : src/env.cpp:93: parameter is null
1456162910 - : cond_is_true: condition is gui, result is 0
1456162910 - : sequence_execute_document: detecting transition. Handle: , condition: gui, next_cur: 1, next_shift: 0, act: 0
1456162910 - ERROR: : src/env.cpp:93: parameter is null
1456162910 - : cond_is_true: condition is NOT silent, result is 1
1456162910 - : sequence_execute_document: detecting transition. Handle: , condition: NOT silent, next_cur: 2, next_shift: 0, act: 1
1456162910 - : sequence_execute_document: next_name = cli_activation_init_error_action
1456162910 - : visited_dialog: 0, top dialog: null, cur dialog: activation_init_action
1456162910 - : dump_debug_info: cli_inst_sequence.xml, activation, activation_init, cli_activation_init_error_action

 

Devorah_H_Intel
Moderator
96 Views

Hello,

Please see Intel® VTune Amplifier XE installation guide:

https://software.intel.com/en-us/Intel-VTune-Amplifier-XE-Install-Guide-Linux

For offline installation you will need to generate the license file, this article explains how to obtain the license file:

https://software.intel.com/en-us/articles/how-do-i-get-my-license-file-for-intel-parallel-studio-xe-...

Please let me know if the above helps.

Regards,

Larry_B_
Novice
97 Views
putting this up here, in case it might be of help to someone attempting an install,
and/or perhaps someone on the Intel dev staff might recognize the issue: 

TL;DR version: 
using a preloaded .so, worked around 2 unresolved functions, in [..]/activation/activation.so

Longer version: 

# nm -D /tmp/install.XXXXXX/activation/activation.so | grep -Pi '9f4df'
[..etc..]
00000000000f4980  T Ox09f4df2d445e589f
00000000000ec320  T Ox09f4df2f39092c7f
                  U Ox09f4df3a72e6a401
000000000014f3b0  T Ox09f4df44222da90e
000000000016f810  T Ox09f4df47247ee5bb
                  U Ox09f4df535973f202
00000000000ffa30  T Ox09f4df5e31fdf639
[..etc..]

#  Work-around:
#  made a sharable containing the following:

  // gcc -m64 -O0 -ggdb3 -Wall -fPIC -shared -o dummy_preload.so dummy_preload.c
  int Ox09f4df3a72e6a401( void ) { return 0; }
  int Ox09f4df535973f202( void ) { return 0; }

  // (no idea what these missing functions might be,
  //  perhaps obfuscated libc or flexlm calls/wrappers ..)

# modified the ./vtune_amplifier_xe_2016_update2, like so:

  --- ./.backups/install.sh;1     2015-12-21 15:48:17.000000000 -0800
  +++ ./install.sh                2016-03-03 20:49:11.089999842 -0800
  @@ -769,7 +769,7 @@

  if [ "yes" = "${skip_gui_install}" ] && [ $online_installer_flag -ne 1 ] ; then
       if [ ! -z "$pset_engine_cli_binary" ]; then
  -        "$pset_engine_cli_binary" --TEMP_FOLDER="$temp_folder" $params
  +        LD_PRELOAD=/root/dummy_preload.so "$pset_engine_cli_binary" --TEMP_FOLDER="$temp_folder" $params
           exit_code=$?
       else
           echo "Missing install binary file. Please check the package and try again."

 

View solution in original post

Light_Intel
Moderator
96 Views

This issue has been resolved. If you have a similar question please start a new thread to ensure your issue is being addressed in a timely manner.

Reply