Community
cancel
Showing results for 
Search instead for 
Did you mean: 
150 Views

Xeon Phi x200 - 10 cores are offline. Bad CPU or BIOS config problem?

Hi everyone,

I am testing out the Ninja DAP platform with Intel Xeon Phi 7210 64-core MIC processor.  After configuring CentOS 7.3, I ran "lscpu" command.  Results of the command show that 10 physical cores (40 HT cores) are offline!  My processor only shows up as 54-core CPU instead of a 64-core CPU.

Did I receive a bad Phi chip?  Or is there anything I need to modify in the SuperMicro K1SPE motherboard BIOS?  My current BIOS settings are quadrant mode, flat memory, all ACPI power statues enabled (P, S, T).

Thank you!

0 Kudos
3 Replies
William_S_8
Beginner
150 Views

Hi Keyur,

This smells like a kernel / x2APIC (read BIOS) problem akin to one I am facing with FreeBSD. You mentioned the K1SPE, but to confirm this is the Supermicro tower?

Under Linux, what output do you get for the following commands:

[ws@bob ~]$ sudo dmidecode --type bios
# dmidecode 3.0
Scanning /dev/mem for entry point.
SMBIOS 3.0 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: 1.0b
	Release Date: 05/24/2016
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 16320 kB
	Characteristics:
		PCI is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		BIOS ROM is socketed
		EDD is supported
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 kB floppy services are supported (int 13h)
		3.5"/2.88 MB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 5.11

and:
 

[ws@bob ~]$ uname -a
Linux bob 3.10.0-327.36.3.el7.xppsl_1.5.1.4151.x86_64 #1 SMP Tue Feb 7 22:40:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

and:
 

[ws@bob ~]$ cpuid -1 -l 1/edx
...
# output omitted as it's huge

 

SergeyKostrov
Valued Contributor II
150 Views

>>I ran "lscpu" command. Results of the command show that 10 physical cores (40 HT cores) are offline!.. Could you upload lscpu command output?
Vivek_P_1
Beginner
150 Views

I have some issues with mics in my system. I tried micctrl --reboot and here is the output I get:

mic0: shutting down
mic1: shutting down
mic2: shutting down
mic3: shutting down
mic0: ready
mic1: ready
mic2: ready
mic3: ready
mic0: booting /lib/firmware/mic/uos.img
mic1: booting /lib/firmware/mic/uos.img
mic2: booting /lib/firmware/mic/uos.img
mic3: booting /lib/firmware/mic/uos.img
mic0: ready
mic1: ready
mic2: ready
mic3: ready

As you can see none of the mics are online. This is preventing me from sshing to one of the mics. Any possible solutions as to how to bring them online?

Reply