Software Storage Technologies
Virtual RAID, RSTe, and Memory Drive Technology
Announcements
Looking for our RealSense Community? Click HERE

Looking for RAID, VROC? You found the forum to ask questions!
317 Discussions

HP 8300 i7-3770) upgraded to Win10 now USB 3.0 only at USB 2.0 Speed

SkiRescue911
Beginner
1,206 Views

I upgrade my HP 8300 (i7-3770 processor, HP 3396 motherboard, chip set Intel 7 Series/C216) from Win7 Pro to Win10 Pro.  external HDs on rear USB 3.0 port only run at 2.0 speed. (~25-30MB/s).  I'm guessing it's a driver issue.  Tried "Update Driver" from Win10 Device Mgr but it says the "best drivers... are already installed".  Suggestions for getting my USB speed back up to 3.0 on this machine?  

0 Kudos
4 Replies
n_scott_pearson
Super User
1,190 Views
You need to manually install the chipset device software (a.k.a. INF Update) package. You need a window 10 version that still has support for chipsets this old. I believe you need a version 9.4 or better but less than 10.0 (which removed support for these older chipsets).
Hope this helps,
...S
P.S. You probably shouldn't have upgraded from Windows 7 to Windows 10; it rarely goes well. A clean install avoids the issues with the older drivers and especially with USB.
0 Kudos
SkiRescue911
Beginner
1,173 Views

@n_scott_pearson:  Thanks very much for the reply!  I found some documentation on v9.4.0.1026 but Windows 10 is not listed as a supported OS.  Your thoughts?

 

Perhaps I misspoke in my post (should probably have said "install" rather than "upgrade").  My Win10 pro install on this HP 8300 was from scratch onto a new SSD drive. 

0 Kudos
n_scott_pearson
Super User
1,156 Views

Hhmmm, a from-scratch install should have picked USB up from the inbox driver set. Still, I always recommend installing the Chipset Device Software package to ensure best configuration of the standard devices. I was off in my numbering; the Windows 10 support started with version 10.0.0. While I could not determine which release dropped the support for 3rd gen systems, I did find a link for version that is prior to that point and does have entries for 3rd gen: https://www.intel.com/content/www/us/en/download/18685 (just ignore the fact that is says for NUCs).

...S

0 Kudos
SkiRescue911
Beginner
1,142 Views

...again - thanks for the help!  I installed the Chipset Device Software per the link you provided.  Afterwards the drive in question started operating at ~125MB/s -yeah!  ...but reverted back to ~25-30MB/s after a system restart.  I haven't been able to determine how to get it back to high speed.  Very frustrating!

0 Kudos
Reply