Showing results for 
Search instead for 
Did you mean: 
Community Manager

320 Firmware Upgrade Failures

I have two bricked 320 drives that I am unable to update the firmware on. Has anyone actually been successful and if so, how did you do it? So far I've tried both the SSD Toolbox v3 and the firmware update boot CD and while the drives are recognized all updates fail. I've tried this using the following SATA controllers: Intel, LSI, DELL, Silicone Image, Marvel, and HighPoint.

One of the drives is a 120 GB and it seems that for whatever reason it cannot be written to, while the drive is recognized and shows 120GB capacity it cannot be initialized or erased. When I tried updating the firmware with the SSD toolbox it came back with error 86. Anyone know what that means? The second drive is 80GB and has the 8MB error, any attempt to update the firmware results in a SMART error message regardless of what I set it to in BIOS.

This is beyond frustrating, I spent $500 on Intel drives and both failed in a matter of months. To add insult to injury Intel seems less than helpful in replacing the drives, they expect me to PAY for shipping after all the money I spent and time I wasted and tell me it's going to take weeks to get the replacement with the risk that they'll fail again. Sorry, that's just unacceptable for a premium product. I went with Intel because of its reputation for reliability and have to say I am severly disappointed. In the meantime I replaced the drives with OCZ SSDs and so far they haven't given me any issues whatsoever and were less expensive on top of it.

0 Kudos
0 Replies