Showing results for 
Search instead for 
Did you mean: 
Community Manager

600p incorrect function


I installed a 256 GB 600p ssd in a MSI GL62 6QD laptop with W10. When I try and initialize the disk using Disk Management, I get and "Incorrect function." response from the Virtual Disk Manager. I can see the drive in the bios and I can see the drive properties.

I have tried this:

1. I had a 2nd HHD, a WD black 1TB HHD for storage only and it was initialized as GPT

2. I set the bios UEFI, Secure Boot, boot from USB first

3. Using RUFUS, I "burned" Windows 10 Pro to a USB drive with settings at: GPT partition for UEFI computer, FAT32, Create a bootable disk using ISO Image (after selecting the Windows 10 ISO you

might have to change the file system back to FAT32

4. With the ISO usb inserted restart and select the USB key with the prefix (UEFI)

5. When the Windows 10 setup screen comes up choose the Intel m.2 ssd and windows 10 will automatically set up the ssd with the right partitions for a GPT disk in UEFI as long as you have the bios set to UEFI, Secure Boot and Legacy mode disabled. If you have the OS installed on the other HHD, best either disconnect it or delete the OS partitions during the SSD OS install before selecting the SSD to install Windows 10.

6. You won't need to initialize the SSD since Windows 10 automatically initializes it in GPT to match the bios setting."

Honestly from the lack of support from Msi and Intel I am deeply disappointed. Thinking about going back to the store and getting a samsung or toshiba drive instead.

The instructions for this device and the unclarity is A JOKE.

Everything needed should be available easily and quickly.

If I need some irst or nvme driver i can put on a usb to load while in win10 installation they should freaking be available.

I've wasted over 9 hours trying to get this god forsaken SSD drive to work, with no help from the "all mighty" Intel who doesn't have any support available over the weekends.

0 Kudos
1 Reply
Community Manager

Hello Alldino,

We understand you are having a problem trying to initialize your SSD. First of all, we would like to let you know that there is a thread already created for this same error message, and we will be working on that one. /thread/108424 Here is the link.

Please follow the latest recommendation on that thread, which is to try to initialize the SSD in a desktop supported computer.

Also, please post in the other thread if you need to use the SSD for booting or storage purposes.