Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,714 Views

80GB X25-M (1st gen) causes all other disk I/O to freeze

I just purchased an 80GB X25-M (1st generation, SSDSA2MH080G1GC) from ncix.com and would like to use it in my desktop. Here is some relevant information:

Motherboard: Gigabyte P35-DQ6, BIOS version F5

Processor: Intel Q6600 @ 2.4 GHz

OS: Vista SP1 Business Edition, 64-bit

On-board SATA settings: AHCI mode, legacy IDE mode

On-board SATA BIOS: Serial ATA AHCI BIOS, Version iSrc 1.07 08042006, (c) 2003-2006 Intel Corporation

Slot-based SATA: Silicon Image SiI-3124, BIOS version 6.4.09

SSD firmware: 8820

I am connecting it to my desktop both via one of the on-board SATA ports (which was previously connected to one of my WD 640GB Caviar drives) as well as using my Thermaltake BlacX eSATA dock (which is plugged into the SiI-3124, 4-port eSATA adapter).

At first, I used the eSATA dock and everything appeared to work reasonably well. The SSD immediately showed up in the Disk Management snap-in, and I was able to initialize and partition it. I ran HD Tune Pro 3.50 to see what numbers I could get. I was only seeing about 110 MB/s sequential reads, but I blame that on the old 32-bit 33-MHz PCI eSATA adapter. I then decided to move the SSD over to one of the internal SATA ports, figuring I could get better speeds if I bypassed the legacy PCI bottleneck. That's when the problems began.

At first, the drive showed up just fine after a reboot, and I started to re-run the tests. However, part way through a benchmark, HD Tune would freeze. The other running apps seemed to be fine. Eventually, HD Tune would unfreeze and report that the benchmark could not be completed. I could see in Vista's Event Viewer that the SSD had disappeared from the system. Windows Explorer confirmed this.

I disconnected the SATA cable from the drive (leaving it powered on), and reconnected it. Still no drive. I disconnected and reconnected both power and data cables, and the drive re-appeared. I tried the benchmark again, and again HD Tune would freeze part way through. I disconnected the drive from the internal SATA and placed it back in the eSATA dock, where it had worked previously. This time, the volume never appears. When I try to bring up Disk Management, it freezes trying to connect to the Virtual Disk Service. I notice now that Explorer also hangs when attempting to bring up a list of mounted volumes. Same with diskpart and mountvol. When I power down the dock and disconnect the drive, everything wakes up and continues as normal.

Event Viewer shows multiple warnings and errors regarding "The device, \Device\Harddisk8\DR12, is not ready for access yet", "The driver detected a controller error on \Device\Ide\IdePort6", "An error was detected on device \Device\Harddisk8\DR12 during a paging operation", and finally "The device 'INTEL SSDSA2MH080G1GC ATA Device' (IDE\DiskINTEL_SSDSA2MH080G1GC___________________045C8820\5&2d74fded&0&4.0.0) disappeared from the system without first being prepared for removal."

So... what would cause the drive to function fine at first, and then cause these problems later? I was certain that this was caused by a defect in the SSD itself, but it works perfectly fine on my Thinkpad T60p laptop, both in the internal SATA drive bay and in the Ultrabay. I've installed Windows 7 RC on it to do some testing, ran several benchmarks, installed and ran my usual suite of apps (Firefox, OpenOffice, cygwin, Photoshop, etc.). Disk Management identifies, partitions and formats the SSD with no issue whatsoever.

Here are some screenshots from my desktop, in case there is information I missed:

0 Kudos
3 Replies
idata
Community Manager
94 Views

You could try enabling SATA Port0-3 Native Mode. I have the Gigabyte EX38-DS4 running in AHCI mode and was told by a Gigabyte moderator that setting should be enabled.

idata
Community Manager
94 Views

Yep, tried native mode SATA as well, and it did not help. Tried various settings on a friend's i7 motherboard and saw the same performance delta. He also has a 1st-gen 80GB X25-M as well as one of the OCZ SSDs. Both of his were performing close to advertised specs, but mine was definitely slower. This difference was significant and repeatable. I've sent the SSD back to ncix.com for a refund.

idata
Community Manager
94 Views

The other thing I see that puzzles me is in the BIOS you have an option to enter RAID utility. If you are doing RAID, then instead of AHCI you should have selected RAID. Also, if you are doing RAID, that could have a negative affect on writing to disk.

Reply